Showing results for 
Show  only  | Search instead for 
Did you mean: 

OneAgent installer for AIX is not working


Hello Folks,

We are tried OneAgent installation on AIX but it is unsuccessful and giving below error,

Error: Cannot determine platform or platform not supported: <AIX>

Host is having OS version 6.1 and CPU architecture as POWER7 and as per the documentation, AIX 6.1 is supported however CPU architecture support is for POWER8 64bit, POWER9 64bit.

Even though it seems to unsupported but we have another host with same system configuration but it has OneAgent running successfully. (This was done in past by some other person and we don't have any steps that he/she has taken to do the installation successfully)


Has anybody encountered in the same situation earlier and did the OneAgent installation successfully on AIX 6.1 POWER7 CPU?






Hi Team,

I would really appreciate your help on this.




DynaMight Guru
DynaMight Guru

Hello @AK 
Yes. The POWER7 CPU architecture is not supported, therefore, you are facing this issue.

When was the other server was instrumented?

What is the OneAgent version on that server?

Are both servers have 6.1 TL9 SP9?

There is no code module auto-injection for AIX 6.1. Installation on AIX WPARs is not supported.



Hi Babar,

I don't have that detail when it was instrumented but OneAgent version on this host is 1.179 and yes, both the servers have 6.1 TL9 SP9.


We are having AppMon agent installed on these Hosts hence there is a need to update it to OneAgent.



Hello @AK 

Did you try to install the same version (1.179) on the second host?




This will likely not work if this is a new installation. Very Old agents (not sure how old, but definitely more than 1y old) are not allowed to connect to Dynatrace cluster in new versions. At least this is my experience. 

Anyway - I don't remember OneAgent supporting POWER7 - but I'd give it a shot. I'm sure @Bartek_Gatz knows the answer if this was supported or not.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner


Do you have any information on this?

Yes Babar, I tried that too but that resulted into same error,

Error: Cannot determine platform or platform not supported: <AIX>




we suspect a bug from the script.


This is the function where the message appears and the installation is aborted (by return 1):

checkSystemCompatibility() {
local expectedPlatform="LINUX"
if [ "${ARCH_ARCH}" = "AIX" ]; then

local platform="$(uname | sed -e 's/_.//' | sed -e 's/\///' | tr '[:lower:]' '[:upper:]')*"
if [ "${platform}" != "${expectedPlatform}" ]; then
printf "Cannot determine platform or platform not supported: <%s>" "${platform}"
return 1

local detectedArchitecture
if ! detectedArchitecture="$(arch_checkArchitectureCompatibility)"; then
printf "Cannot determine architecture or architecture not supported: <%s>" "${detectedArchitecture}"
return 1

printf 'Detected platform: %s' "${platform}"
if [ "${detectedArchitecture}" ]; then
printf ' arch: %s' "${detectedArchitecture}"

return 0


At line 1044 of the script you can read :

readonly ARCH_ARCH="X86"

This means the ARCH_ARCH is a constant that can't be modified so it will always be "X86".

Since the script is made for an AIX platform, it does not make any sens.


We opened a support case for that.

Forget my comment...

I used a wrong url to get the binary oneagent.


wrong command:

wget -O "" --header="Authorization: Api-Token xxxxx"


right command:

wget -O "" --header="Authorization: Api-Token xxxxx"

Hi @AK,

I did an Installation on those kind of system when I was at 1.175 and even if it was on POWER7 it worked.

So, mon ami, my suggestion is the following:

first of all try to uninstall every little piece of old agent that you have, following the doc.
then download the oldest version of oneagent that you have at your disposal:

-in order to do so, go in your environment, and go to the Environment Api v1; call those sweet apis.
The number 1 to list the oldest version for your env, the number 2 to get the oldest version:




Now go and try to install it, and then try to upgrade it.

Good luck

Hi @y_buccellato,


I can see following versions for AIX. The lower is "1.173.314.20190809-152259"

This seems to be very outdated version. Will it communicate to dynatrace SaaS "" without any issue?




DynaMight Legend
DynaMight Legend

Most likely not - if this is a new installation. With recent Dynatrace versions new installed agents of an old version will be refused from connecting to the cluster. But I'd give it a try anyway.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

@AK , sorry for the delay 🙂 working a lot!

To be completly open with you: we are in the field of "you need to try if this work for you".

If I were you I'd try the oldest or the second oldest (in you case 1.7* or 1.8*).

There is a very high probability that the agent won't connect to your environment cause of the gap between your server and the agent itself.

As an example the first time I experienced that was with an outdated version of Dynatrace daemon set for Openshift: the installation went smooth but then I could not see anything in the deployment status and a pop-up banner appeared in my environment telling me that I had to update an agent.

If you have an enviroment active gate you can also very that on the rejection.log (if I'm not mistaken)

As a I final solution, if your old agent doesn't connect, you can open a ticket to Dynatrace and see if they can allow oldest version to connect to your Tenant.

That's pretty much everything you can do 🙂

Have a great day!


Thank you for your suggestions. Apologies for late comments on the topic. The host is not under our custody hence it is taking time to do test the installation.


I did the installation and it went successful however, I found few strange things and issues,

1. I tried to get the all OneAgent versions available for download in my environment using regular API token but it gave below error,

"error": {
"code": 403,
"message": "Token is missing required scope. Use one of: InstallerDownload (PaaS integration - Installer download)"

Then I realize that, the normal API token will not work and I need to generate PaaS token to use those kind of APIs (Correct me if I'm wrong)

I generated a PaaS token and downloaded the installer for AIX - 1.173.314 and copied to concerned host. (The only difference I can observe from the regular steps is PaaS token in the command rather that API token and below is the GET URL I used to download 

I ran the installer for 1.173.314 on the host and checked a agent version under host UI and it was 1.215.163

2. I checked with Chat support as how installed agent version is showing 1.215.163 when ran the installer for 1.173.314 in reply they asked "Are these host deployed to a PaaS environment?"


Now the question is,

1. Have I deployed the agent using PaaS deployment? (I'm not at all sure on this as I never did this kind of deployment)

If yes, what is the difference in regular and PaaS deployment and Is there a way to check the host which are deployed as PaaS environment?

2. We are successful in installing the OneAgent for unsupported AIX version but will deep dive monitoring work fine? because, I can see the warning message for all processes stating that,

This process isn't fully monitored
Deep monitoring of this process has not been setup. You're missing out on crucial process- and service-level monitoring insights. Enable monitoring as described




Hi @AK 

about the paas token it's good that you found the solution on your own!
From my understanding you only downloaded the agent with a paas token e then you installed it on an local AIX host via shell script.
So you should have deployed the agent in a "business as usual way". I'm not aware of any difference.

About the version of oneagent on which you are now: you can download the support archive from the host page WebUI by clicking the "three dotted button" an then clicking the "Run One Agent Diagnostic" button.

After you download the archive locally, you open the zip and you go here


you open the host_entity.json and you look for "INSTALLER_VERSION".

This way you'll know for sure on which version of oneagent you are and you can act accordingly to the doc for the deep instrumentation process:

Again, no guarantiee since you are installing on a system that is out of support (if you have a pre-prod environment or host I strongly suggest you experiment there first 🙂 )

Let us know how it went!


Thanks for your kind reply and help. Sorry for so much questions 😉.

The good news is, I'm successfully able to do deep dive monitoring for processes on AIX 6.1 now.

I followed the steps given in the documentation (Three lines given in the document added at the start of weblogic startup script) and after restarting the services it worked fine. 


As I'm using OneAgent below the 1.187 hence the above steps were necessary.

I didn't got a chance to check the oneagent version on host via Host UI as I don't have elevated permissions. (May be, I will check tis once I have sensitive data view permission)


Thanks team for your help and valuable comments. I really appreciate it.




Featured Posts