Showing results for 
Show  only  | Search instead for 
Did you mean: 

Are there any limitations of @dynatrace/react-native-plugin with emulators?


When I run my application (IOS) from the command line on an emulator I can't identify the logs but when I run it directly through xcode I can. Is there any explanation?

On Android, when I run it for the first time of the day I can retrieve the logs on the platform. The other times I try I no longer succeed


Dynatrace Pro
Dynatrace Pro

Can you explain how you are starting for example Android. Are you starting it via Android Studio? Or npx react-native run-android? Are you executing this command each and everytime? Or how is the second start done?

DynaMight Guru
DynaMight Guru

Hi @antoniosvuono 

When you run an iOS app from the command line, you might not have the same level of integration with the logging system as Xcode provides. To view logs in this scenario, you can use tools like on your Mac or log command line tool to access the device's log. Ensure that your command-line tools are correctly configured to capture the logs.


Have a nice day!

Featured Posts