cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Auto inject of DT Ruxitjs script not working

Hi All , I am facing a challenge is monitoring user experience of an application. In some pf the pages , ruxitjs is auto inserted, in many it is not. I am able to see dtcookie , dtsa etc in all these pages. Can someone suggest a troubleshooting step.


Thanks

Swati

8 REPLIES 8

Hi @Swati B.

Check documentation on Why don't I see my applications or monitoring data?

There you will find step by step checks

HTH

Yos

dynatrace certificated professional - dynatrace primer partner - Matrix Soft Ware Division - Israel

hi @Yos N. thanks for your reply. There is no troubleshooting step given in https://www.dynatrace.com/support/help/how-to-use-dynatrace/real-user-monitoring/setup-and-configura... . in my application some pages dont have javascript tag injected.

Hi @Swati B.

Please scroll down on that page and look for the follows lines and open them one by one

dynatrace certificated professional - dynatrace primer partner - Matrix Soft Ware Division - Israel

hi @Yos N. this article is not useful. There is no mention of troubleshooting steps in case JS is not injecting in pages. The first step How can I confirm the JavaScript tag is injected correctly? holds true . There is no JS injected. But there are no further steps as what do to next.


Hi @Swati B.

Here are the rules specify the criteria for determining a suitable location within an HTML document to inject the JavaScript tag.

Check if your pages compile with those rules.

HTH

Yos

dynatrace certificated professional - dynatrace primer partner - Matrix Soft Ware Division - Israel

I also observed unsual value of dtSa cookie . in other applications dtSa cookie has blank value. Is it an issue?

Domenico_Bressi
Advisor

HI @Swati B.

i take same experience with some of my applications where HTML header was more then 1000 digit. in this case javascript injection did not work property or other javascript stay on top of the code. check to all tag are <>closed </>

In this case try to force Javascript injection in the configuration of your Dynatrace application. Try to put Script near <head> to be sure is the first think you load in the page

Application- edit

in Application settings

Setting--> advance setup-->JavaScript injection (section) --> add custom rules
example:  All pages ( After specific HTML <head> )

Thanks @Domenico B. I will check the header and see if that is the issue.