cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to configure cluster activegate to works in HTTP

a_chiaravalle
Participant

Hi Team

For performance reason, I want to use our load balancer to terminate the SSL connections and send clear http sessions to Cluster Activegate, to do this I changed the Cluster ActiveGate URL (in CMC-Settings-Public endpoint) in this way:

https://<Cluster Activegate IP>:9999

to

http://<Cluster Activegate IP>:9999

And restarted the cluster activegate, anyway if I try to do this get (an agentless javascript tag)

http://<Cluster Activegate IP>:9999/jstag/managed/3c0d5af8-83de-4ad0-90e8-315adf6fa7df/ff682499541a3...

I have this reponse:

ERR_INVALID_HTTP_RESPONSE

and the cluster activegate continue to respond in https:

https://<Cluster Activegate IP>:9999/jstag/managed/3c0d5af8-83de-4ad0-90e8-315adf6fa7df/ff682499541a...

(function(){(function(){function a(){if(void 0===b.dialogArguments)return navigator.cookieEnabled;document.cookie="__dTCookie=1";var ..............................................................................................................

Does anyone suggest how to make the cluster activegate works in http?

Regards

Antonello


2 REPLIES 2

siavash_h
Dynatrace Pro
Dynatrace Pro

Hi Antonello,

If this is for agent traffic you have to set the port parameter in the custom.properties file.

https://www.dynatrace.com/support/help/shortlink/sgw-configure#section-comcompuwareapmwebserver-

Sia


Hi Siavash

Thanks for your help, the suggestion has been very helpful.

regards

Antonello