I'm currently analysing an application where multiple areas are clickable, but have the exact same function. E.g. there's a date selector that contains date and price, when you click the date I would get "Click on 01 jan 2019" and when I click in the same block on the price my action would be named "click on $500". But from monitoring perspective I would like to know "Click on date/price selector" (and this could then be a key-user-action...)
When we could influence the naming from using stylesheets, the amount of work would be limited and the impact huge (changing styles is often also possible in 3rd party applications).
Does this functionality already exist (ported from AppMon), or is this a candidate for a RFE?
Solved! Go to Solution.
You have a couple of options I can think of.
The page action and XHR action names can be switched from user input to loading of page X under the settings sections.
Alternatively did you try the user action naming rules?
For instance if you have several actions such as click on $200 or click on $300, you could rename them click on amount. They are plenty more options in this section. Have a look at extraction rules too.
data-dtName will also work with Dynatrace.
And we will improve the action naming rules in future by adding placeholders similar than you can do for service naming.