Showing results for 
Show  only  | Search instead for 
Did you mean: 

No web requests when app is in production


I have integrated Dynatrace SDK into our iOS application. When I run our application locally or download it from Testflight, everything works perfectly. I can see our real Apdex rating, web requests, and crashes if any.

However, when I release our into production and it is on the Appstore, Dynatrace doesn't show any date.
No web requests or crashes. Also, Apdex is 1.0 as a result.

Our cost and traffic control is 1% which shouldn't be an issue because Dynatrace works fine in our Android application. We use the same dashboard for both platforms.

- We have Firebase in our app but we don't use it for Performance Monitoring, I have disabled it just in case but it didn't help.


Dynatrace Champion
Dynatrace Champion


for debugging such an issue I would suggest to open a support ticket at
But I can give some hints to validate before:

Strange thing is the difference between TestFlight ans AppStore release, as there should not be any difference, as you can use the same build.

iOS help:

I have created a separate dashboard just for our iOS app to see if 1% was the reason. However that didn't solve the issue either.
I am using Firebase only for crashlytics but I disabled the performance monitoring just in case. It didn't help.

Dynatrace Champion
Dynatrace Champion

Please open a support ticket so we can have a closer look.

iOS help:

@enum when your issue is solved maybe you can share a solution with other users? They would be grateful to have some hints if a similar issue will appear. 🙂

When passion meets people magic and innovation happen.

Featured Posts