cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Synthetic monitor creation failed with 401

islam_zidan
Champion

Hello,

We are facing an error while we try to create a synthetic monitor on the customer environment, checking the log we found the below error

 

[browser-BeaconSenderService-thread-1910] WARN BeaconSenderService: Failed to send beacon BeaconData[beaconEndpoint: https://localhost:9999/beacon/synthetic/browser/xxxxx-xxxx-xxxx-xxx-xxxxxxx?flavor=cors&app=xxxxxxxxxxxxxxxxxxx type: MessageType{value='BeaconRequest'}, beaconId: 1], got 401 (token: *****####))

 

Any ideas why the AG can't authenticate with the cluster server.

 

thanks,

Islam

Dynatrace Certified Professional - Dynatrace Partner - Yourcompass.ca
5 REPLIES 5

HannahM
Dynatrace Leader
Dynatrace Leader

Please can you create a chat or support ticket so we can check the Synthetic tokens are not stale in you environment. 

radek_jasinski
DynaMight Guru
DynaMight Guru

Hi @islam_zidan 

Please note that you are trying to send a beacon to localhost. Have you verified the configuration of your AG and synthetic monitor?

Radek

Have a nice day!

This is expected in a Private ActiveGate. The beacon goes to the localhost and is redirected to the cluster. The logs just show the localhost connection

Yes, you are right!

Have a nice day!

islam_zidan
Champion

The problem solved after opening a support ticket, to fix the token issue.

Dynatrace Certified Professional - Dynatrace Partner - Yourcompass.ca

Featured Posts