cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Host or Monitoring Unavailable

We are doing autoscaling and whenever we scale down instances we are receiving host or monitoring unavailable alert and we don't that alert to be triggered in this scenario.Can you please help us how can we disable alert.


3 REPLIES 3

Only way I have in mind is maintenance window. During scaling down, you can send request to DT to fire up maintenance window that will cover those hosts that will be disconnected. Than do scaling down, after few minutes disable maintenance window. This is really dirty workaround but I don't have other idea for now.

Sebastian


Julius_Loman
Leader

How exactly are you "descaling" your environment? Probably the best approach would be to uninstall the agents before shutting down the instances. Then you would not get the problems about unavailable hosts.


ctturner
Inactive

@Tarun A. Without being fully aware of your process for autoscaling, I would propose a few ideas. If these devices are defined and chosen prior to the autoscaling action, setup an automatic tag to tag them and have a maintenance window that is set off of that defined tag. That would suppress these alarms.

OR

Within the Alert profile page, select the alert profile and exclude the hosts slated for autoscaling to be excluded from alerts.

OR

Globally, change your settings to not alert on graceful shutdowns and have your hosts shutdown gracefully. This will then not alert you when the host is shutdown. You can also go into the settings page and disable the one agent on the host prior to the auto scaling.


Thank you,

Chad