cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problems sent to Opsgenie seems to not autoclose

AymericM
Participant

In the documentation it is stated :

Opsgenie incidents are automatically created when problems are detected and closed when problems are resolved.

But from our experience only the creation part is working, when the problem is marked as resolved in Dynatrace console it remains open in OpsGenie.

 

I don't see any setting in the configuration of the problem notification to activate or deactivate the sending of the close event.

Is it still working ?

9 REPLIES 9

Thps44
Newcomer

I am having this exact same problem just started in our system recently as well. I've combed through all the setting and even updated the OpsGenie integration to V2 but still alerts are not auto closing. Hopefully a resolution can be found, I will keep looking on my end.

hakanozanlagan
Visitor

we having this exact same problem too. it was working a few days ago. We didn't change any configuration. I think this problem occured after server last update.

AymericM
Participant

I sent a ticket to Dynatrace support. The answer is that Atlassian depracated the V1 of Opsgenie integration with Dynatrace and is pushing the use of their new integration using a webhook in a Custom Integration.

 

The advice of Dynatrace support was to follow Opsegnie documentation : 

https://support.atlassian.com/opsgenie/docs/integrate-opsgenie-with-dynatrace-webhook-v2/

And to make sure to :

- check the box "Call webhook if problem is closed"

- add "PID":"{PID}" in the json.

 

We tried it and it works.

When I add "PID":"{PID}" to the json it strips responders/owners from the alert so it goes to Opgenie but doesn't trigger actual alerts, when I removed the "PID":"{PID}" I get the alert notifications. Did you also see this behavior?  

I don't think we have this problem.

 

You're using the Custom Integration ?

If yes do you add the PID after the default JSON ?
If yes do you add a comma after the ProblemTitle line so the JSO remain valid ? 

{
"State":"{State}",
"ProblemID":"{ProblemID}",
"ProblemTitle":"{ProblemTitle}",
"PID":"{PID}"
}

 

Yes, using custom integration and my JSON is identical, I deleted and recreated the integration and I get the notifications in OpsGenie but it is not assigning an owner or responder even thought the team is added to the integration I am not sure what is occurring. I tried tying it to the escalation process and the team both act the same and are not triggering an alert. 

I think I just figured it out, even though the webhook integration is setup the alerts are coming in via the Default API which was not assigned to a team.

The close alert still does not work for me.

 

Have you got anymore tips/tricks to try?

hakanozanlagan
Visitor

how did you set priority? ProblemSeverity propery is not working.

 

{ProblemSeverity}: Severity level of the problem. Possible values are AVAILABILITY, ERROR, PERFORMANCE, RESOURCE_CONTENTION, or CUSTOM_ALERT.