cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Stop alerting on specific requests

Malaik
DynaMight Advisor
DynaMight Advisor

Hello Community

 

I want to stop alerting for a specific requests (for a specific service).

All GET requests should not alert.

 

I know that I can mute the requests, but with the mute I will skip the statistics (response time, failures...).

So, to resume, I want to keep all the KPI and statistics, the only thing is to not alert.

 

Thanks for your suggestions,

Have a good day.

Sharing Knowledge
6 REPLIES 6

Yosi_Neuman
DynaMight Champion
DynaMight Champion

Hi @Malaik ,

Is it possible to separate the GETs to a different service and then tag it for maintenance window that will not alerts?

Yos 

 

dynatrace certificated professional - dynatrace primer partner - Matrix Soft Ware Division - Israel

Hi @Yosi_Neuman 

 

How can I group all in the same service?

Sharing Knowledge

Yosi_Neuman
DynaMight Champion
DynaMight Champion

Hi @Malaik 

Thought about rest api service detection Rules with condition for WEBSERVICE_METHOD, but I'm not sure if it works or not. 

HTH and will not miss lead you  

Yos 

dynatrace certificated professional - dynatrace primer partner - Matrix Soft Ware Division - Israel

anas_milhem
Dynatracer
Dynatracer

Hey @Malaik !

A workaround you can do is maybe mark the important requests you want to alert on as key requests. You can then turn off response time degradation and failure rate detection for the service but turn it on for your key requests

anas_milhem_0-1654112575610.png


Thank You!
Anas Milhem

Thanks Anas,

 

Yes I was thinking for that but it will take a huge time because the number of requests is too high.

 

I found the temporary solution which is to group that requests and mute them.

 

Its working fine right now, let see.

 

Have a good day.

Sharing Knowledge

techean
Dynatrace Pro
Dynatrace Pro

You can try custom proces detection rule Set up custom process groups for monitoring | Dynatrace news. And than try setting up maintenance window as said by @Yosi_Neuman 

KG