cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why pod restart doesn't alert dynatrace

We running Dynatrace on a gke cluster and when pod restarts it is not shown in Dynatrace, even worst, it shows the old pod as unmonitored.

Hence here is my question, how can I make an alerte on Dynatrace on every pod restart. Just for information I'am running Dynatrace on managed version.


Thanks


5 REPLIES 5

sebastian_kryst
DynaMight Leader
DynaMight Leader

It's because as you don't restart pod but destroy instance and create new one (new ID assigned to OneAgent). As I understand you are using not full stack monitoring but application only monitoring?

Sebastian


No I'am using the fullstack monitoring and we are not destroying instances, it just that pod restart doesn't show on dynatrace properly it display a message that a pod is not monitored or that the signal was lost.


If I take an example: Let's say we have 3 runing process, and all the 3 are restarted, then all the new pod will be display in dynatrace while the old one are marked as unmonitored or "signal lost" tagged.




For example in the above image we can see that the old pod are seen as unmonitored or have a "lost signal" tag.


My question is how can we properly configure Dynatrace to properly show the pod information. Or is this normal and only used to see old pod metrics


This is regular behaviour.

Sebastian


Can we change the normal behaviour so that old pod doesn't show up as unmonitored or tagged with "lost signal" ? Additionnaly is that possible to make Dynatrace makes an alert to any pod restart.


We had the same inquery. We notice that the pod would die before a new one showup.

We configure a minimun of running process for that PG and a minimun of pods in OCP. So in the case of a new pod we get an alert that the PG is lower than it should be.