Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issue with selfsigned certifcate kubernet setup



I have tried setting the kubernet monitoring as per document .. but i have been always getting TLS issue for self signed certificate .. or even invalid token sometime ..

1. Using Keytool - imported the certificate in existing trusted.jks file with passwod trusted

2. Adding entry in file also .

3. Restarted all gateway/agent ..

4. Enter the kubernet URL and token but getting TLS or invalid token issues

Also tried with no certificate options also.. then getting same TLS issue ..

Note : Agent/gateway installed on same rancher-kubernet cluster node ... my server is on different node.

I am able to see docker images due to agent on that node ... but API/Token failing for TLS.

Q: What is right step for connection...

Q. Is it fine to use existing trsuted.jks ( i have tried even with jks file)

Q. Will not this work with self signed certificate

Q. Is certificate need to be generated on a node where agent and activeagete installed ?


DynaMight Guru
DynaMight Guru

We had similar issue, you have to add your ROOT CA certificate to ActiveGate, than it will accept certificate you have on Kubernetes side.


Regards, Sebastian

Thanks Sebastian!! ... We notice .. it does not work with rancher certificate ..But work with Kubernet directly.

Featured Posts