Showing results for 
Show  only  | Search instead for 
Did you mean: 

OneAgent and MiniShift


Hi! we are testing the oneagent operator in Minishift. The deploy of full stack agent works just great, but no process get injected, event after starting new pods or leaving the pods at 0 by a few minutes.

All pods keeps saying that a restart is need it. We started new ones, build new ones and I restarted the minishift enviroment a few times, but always the same.

Checking the support logs i found this failures:

info [native] Detected PA Injection failure for PGI:

Also, checking oneagenthelper log:

severe [docker ] pid 27988: Injection failed for container k8s_sti-build_nginx-test-1-build_test_e4280cab-75ee-11e9-9d3b-525400c47d6f_0

We are doing this to check this before testing in a real openshift enviroment deploy. The Oneagent installed as Operator wont inject, as daemon wont inject. Installed the .sh agent at the linux box, and worked like a charm. After starting varius nginx pods, every single one was injected. (Using Nginx as demo)

Services Solution Engineer @PowerCloud - Observability/CloudOps Certified / Former SE @Dynatrace.

DynaMight Legend
DynaMight Legend

Not sure if this is the same issue, but I also had problems deploying Oneagent via operator on Minishift. If I remember correctly, it was because of how Minishift is build (I think it was readonly root or something similar preventing the injection - maybe it was the LD_PRELOAD setting). The Operator will run the Oneagent as a docker image with elevated rights and with access to the host filesystem.

Anyway, on real Openshift it worked like charm.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Thanks Julius! Reading the logs it looks like it cant mount the agent. So i will asume it might be the same problem.

Great if it worked!


Services Solution Engineer @PowerCloud - Observability/CloudOps Certified / Former SE @Dynatrace.

Featured Posts