Showing results for 
Show  only  | Search instead for 
Did you mean: 

SpringBoot Service Not Detected


Hello everyone,

Recently I just deploy Dynatrace on Kubernetes environment and want to monitor Spring Boot process as captured.



After I restarted the process, there is still no service detected. Is there any additional configuration on Dynatrace that I should do?


Thank you.


DynaMight Guru
DynaMight Guru


Was OneAgent installed in Full Stack mode? Have you generated some traffic in your application?

Best regards

❤️ Emacs ❤️ Vim ❤️ Bash ❤️ Perl

Exactly, it looks, like it's not being deeply monitored. What deployment model of Dynatrace into Kubernetes are you using?

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Hello Julius,

I'm using this kind of Kubernetes deployment (captured below) for the EKS. Only from here and then I restarted the process (the pod/container).



As far as I know, Kubernetes deployment as captured below, the nodes will directly become fullstack mode.




Yes, that's true. Any chance you are looking at the old data? 
I'd recommend downloading a support archive a have a look into what is going on here.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

What kind of support archive file do you need?

And also, lately I checked on deployment status, there is notification state that Process is ready to be monitored, waiting for injection status.




I would recommend you restarting pending processes and check it again.

Best regards

❤️ Emacs ❤️ Vim ❤️ Bash ❤️ Perl

Choose OneAgent Diagnostic:


Then run the diagnostic


and then you can download the support archive.

You can also reach out to Dynatrace One for helping you with collecting the data or interpreting the results. Looks like the injection is not working for some reason in your environment and it's important to check the OneAgent logs.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner



We have the same problem. We would appreciate any help if you have found the solution.


Thank you very much.


We have opened a case with Dynatrace and it seems that in our case the problem is that we are using JAVA OpenJDK v18.0.2 and this version isn´t supported as it is described in the following link: 

We have tried a microservice with versión 19 and the problem seems to be fixed.

Hope this helps.

Hi drolano, yes correct.

We also finally run OneAgent Diagnostics as @Julius_Loman suggested.


In result, it is because we are using Java Amazon Coretto 18 and it is not supported by Dynatrace anymore.



So it means that we should suggest our user to change their Java version right? 😅

Yes, Dynatrace support only LTS versions and non-LTS version during the time when the vendor supports it. If you look at the Java vendor support itself (not Dynatrace support of Java 18), it ended in September 2022. So actually you should have a supported JVM version regardless of having Dynatrace or not.

You can see current supported JVM versions by Dynatrace here.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Featured Posts