Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error with building table that shows dead messages in RabbitMQ


I'm trying to build a simple table showing the dead messages in RabbitMQ.

In the data-explorer tab I'm running this query:
builtin:tech.rabbitmq.topN_queue_messages_ready:filter(in("queue", entitySelector("entityName.contains(~"dead~")"))):sort(value(auto,descending)):limit(100)

but it's not working due to:
Metric selector parse error: Illegal criterion: `entitySelector("entityName.contains(~"dead~")")`

What am I doing wrong?
Thank you in advance for your time and suggestions!


Dynatrace Helper
Dynatrace Helper

Entity selectors can only be applied to entity dimensions, the "queue" dimension in this metric is of type String.

Thanks for your reply!

Is there a way to apply a filter "contains" on the queue dimension then? I tried but I couldn't find a way to do it. Most likely it's just my poor understanding of the syntax, sorry if it's a basic question...

Dynatrace Helper
Dynatrace Helper

filter(contains("queue", "dead")) should do the trick.

Will be hopefully added to the documentation soon.

Thank you, that's very helpful and solved my issue!

Featured Posts