Showing results for 
Show  only  | Search instead for 
Did you mean: 

Create a App Error


2024-04-24 11-51-23_Start.png


I am trying to build an App using the tutorials available at

The first error was due to the following line where npm folder was not created after node js installed. 

The error is 

npm ERR! code ENOENT
npm ERR! syscall lstat
npm ERR! path C:\Users\XXXX\AppData\Roaming\npm
npm ERR! errno -4058
npm ERR! enoent ENOENT: no such file or directory, lstat 'C:\Users\XXXX\AppData\Roaming\npm'
npm ERR! enoent This is related to npm not being able to find a file.
npm ERR! enoent

After manually creating the npm folder,However, The process finally fails with the following error. 

Searching for template repositories...Error reading repository archive: TypeError: fetch failed
at node:internal/deps/undici/undici:12344:11
at process.processTicksAndRejections (node:internal/process/task_queues:95:5)
at async by (C:\Users\XXXX\AppData\Local\npm-cache\_npx\c71cbee634d2345c\node_modules\dt-app\lib\src\bin.js:145:3921)
at async wy (C:\Users\XXXX\AppData\Local\npm-cache\_npx\c71cbee634d2345c\node_modules\dt-app\lib\src\bin.js:145:3662)
at async dp (C:\Users\XXXX\AppData\Local\npm-cache\_npx\c71cbee634d2345c\node_modules\dt-app\lib\src\bin.js:145:4865)
at async up (C:\Users\XXXX\AppData\Local\npm-cache\_npx\c71cbee634d2345c\node_modules\dt-app\lib\src\bin.js:148:182)
at async Command.<anonymous> (C:\Users\XXXX\AppData\Local\npm-cache\_npx\c71cbee634d2345c\node_modules\dt-app\lib\src\bin.js:178:1336) {
cause: Error: read ECONNRESET
at TLSWrap.onStreamRead (node:internal/stream_base_commons:217:20) {
errno: -4077,
syscall: 'read'
× Searching for template repositories...
Error: Could not retrieve templates from the template repository.


The order of execution of the steps can be seen in the screenshot attached. 

Node JS Version is V20.11.0 

Windows 10 OS 64 bit 

Also, Was just wondering if I need to do any steps after Node Js (V20.11.0) is installed ?



More details : Tried both ways with and without the templates parameter.

Dynatrace Champion
Dynatrace Champion

Hi @DD_Developer 


It looks like github is blocked by a firewall. can you maybe run this command in the windows terminal and check if the connection check was successful?

> tnc -port 443

ComputerName     :
RemoteAddress    :
RemotePort       : 443
InterfaceAlias   : Ethernet 2
SourceAddress    : <private ip>
TcpTestSucceeded : True


if github is blocked, you could try to use an older version of the dt-app toolkit which does not rely on github

npx dt-app@0.115.5 create




@sinisa_zubic , 

Thanks a lot. The command below worked. 


npx dt-app@0.115.5 create



May it helps for other users, 

In the Command Window, The following command didn't work , The same command worked fine with TCPVariableSucceeded attribute as true in PowerShell.



 tnc -port 443




Featured Posts