Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error when calling an AppFunction in a CustomApp


Hello my friends!

I'm getting an error when I try to call an AppFunction on my custom App, I have already created and used AppFunctions, but I am having this error in a new App, I will put the error log below:


I don't know if it's just a missed config or something that I did wrong, thank you for your help. 🙂


Dynatrace Helper
Dynatrace Helper

Hi @MaximilianoML,

Thanks for reaching out. Can you let us know which versions of Node.js and the Dynatrace App Toolkit you're using? You should be on the latest LTS of Node.js and the latest version for the toolkit. You could also try to delete the node_modules folder and follow up with an "npm install". Let us know if this helps.


Hello, @SarahFaustmann,

First, thank you for your support!

Okay, I'll try to update my Node to the latest LTS version and then delete the Modules, when I have the results I will let you know.

Thank you again 🙂

Hello, @SarahFaustmann !

I apologize for the delayed response, I updated the Node to the LTS version but the problem persists, I will attach an image that shows the error (which also occurs during the deployment attempt).



I also got these errors when running the local server.



Dynatrace Helper
Dynatrace Helper

Hi @MaximilianoML 

Given your receiving a 401 error, the next best practice would be to check if you have the required permissions within your environment. This will need to be changed in the IAM policies: 

You can also read more about AppEngine Policies in this blog. 

If your not able to do this you may need to contact your Dynatrace Admin to help you set this up. Hope this helps.

Thanks, Penny

Hello, @PennyScully !

Actually I already have the permission to do, because I've developed a custom App with no problems, and this morning I tried to call my App Function and worked but to deploy doesn't work.

But since last week I'm getting these erros.

Thank you again! 🙂

Dynatrace Advisor
Dynatrace Advisor

Hi @MaximilianoML 

What is the error message you're getting when deploying? The one that you sent before? 

If yes, that's perhaps the issue with your authentication. Could be number of reasons such as auth token expired and so on.

Can you provide more details?


Hello @imsingh !

Yeah, about this problem I already opened a ticket so we don't need to look into this... but about my AppFunction is not working again and I definitely didn't change anything... I don't know what's happening.

My Node is the LTS Version and I already deleted and run npm install again and no results.




Is it possible to share a redacted version of your app function? If not, I think going to support is the right approach if you can't share your things publicly. 

I can, it's just a Fetch and return.



Dynatrace Advisor
Dynatrace Advisor


Hi @MaximilianoML 

The issue that you have is with authentication and that's the reason for having issue with seriazling data and also when deploying. 

I think support is the right thing to do. However, if you want to pinpoint the issue, you can remove the functionality of this app function and deploy the app. Most likely you'll be able to deploy. 


Also, check the token value. Is it valid, does it have required permissions?

Featured Posts