Showing results for 
Show  only  | Search instead for 
Did you mean: 

Is HTTP API call allowed?

Dynatrace Enthusiast
Dynatrace Enthusiast

Is it allows to call an API with HTTP and not HTTPS within an app function? My function works locally, but not when I deploy it. The URL is registered in the allow list of the outbound connection. 


Dynatrace Helper
Dynatrace Helper

Hi Simon,

I've just tried it out myself in Notebooks to confirm. If the domain matches an entry in the allowed list of outbound connections, also HTTP connections work. However, it's not recommended to do that, but I assume you know.


I tried the same as you did, but I get the following error:
When I copy/paste the same url in the browser the call works and returns the correct result.



Could you please double check if you've entered the endpoint in the right list? The error message in your screenshot talks about "edge requests" which lets me believe you've entered the URL in the wrong list.

If the URL you're using is located in a private network, you should check if the correct host-to-locations mappings are defined in the settings for EdgeConnect.

You can find it under Settings -> Preferences -> Data Gateway Locations.


Your AutomationEngine ally!

Thanks that solved it for notebooks.

But in the app I still get an error. Do I need to set something in my app? 



was needed.

Dynatrace Promoter
Dynatrace Promoter

It turned out that this was a misconfiguration where the error message was not helpful at all to resolve the issue. I will create the necessary issues to improve the error message.

Featured Posts