Showing results for 
Show  only  | Search instead for 
Did you mean: 

Setup of new app failing with Installing the dependencies failed.

Hi All, 

I have a new laptop and when I try to create a new app it fails with below. Is there something I am missing in the installation of Nodejs or a step I need to run to get it to work?




Dynatrace Helper
Dynatrace Helper

Hi @brett_schubach1,

I was able to create a new app using the same node and dt-app versions as you. Have you checked for connectivity issues?

Kind regards,

@SarahFaustmann I don't believe it is an issue with connectivity I have ActiveGate and OneAGent running and they are running fine. Also if I copy an old application to my new laptop and run it it connects fine.  On my old laptop, I get the same error when trying to create a new application but the old ones to the same tenant run 100% on that laptop I uninstalled the previous version 18 and after that no matter what I do it fails. I also tried with the trailing / in case that was the issue. I believe something is not right with the Nodejs as no matter which version I use it fails. But I am not sure why and I am not a Nodejs  guru. 🙂

Hi @brett_schubach1,

One of the first steps in the connectivity troubleshooting guide I linked above is to check if you can access the npm registry. Since the step that failed was installing dependencies, this may be your issue.

Kind regards,

@SarahFaustmann Thank you for the troubleshooting steps but seems it is still not working. All the output I get is exactly like in the troubleshooting guide. Still failing with the same issue.

My install I chose


I didn't install this part 



Here is an example of the logfile 


2024-04-29T22:23:10.699Z DEBUG [TELEMETRY] Reporting event
2024-04-29T22:23:11.554Z DEBUG [FILES] CREATED: C:\mediro\test\.vscode\launch.json (1.16 KB)
2024-04-29T22:23:11.555Z DEBUG [FILES] CREATED: C:\mediro\test\.vscode\tasks.json (0.67 KB)
2024-04-29T22:23:11.556Z DEBUG [FILES] undefined C:\mediro\test\package.json (1.48 KB)
2024-04-29T22:23:11.556Z DEBUG [FILES] CREATED: C:\mediro\test\app.config.json (0.36 KB)
2024-04-29T22:23:11.556Z DEBUG [FILES] CREATED: C:\mediro\test\.eslintignore (0.03 KB)
2024-04-29T22:23:11.556Z DEBUG [FILES] CREATED: C:\mediro\test\.eslintrc (1.14 KB)
2024-04-29T22:23:11.558Z DEBUG [FILES] CREATED: C:\mediro\test\.vscode\extensions.json (0.07 KB)
2024-04-29T22:23:11.558Z DEBUG [FILES] CREATED: C:\mediro\test\ (1.59 KB)
2024-04-29T22:23:11.558Z DEBUG [FILES] CREATED: C:\mediro\test\.gitignore (0.51 KB)
2024-04-29T22:23:11.559Z DEBUG [FILES] CREATED: C:\mediro\test\src\app\App.tsx (0.55 KB)
2024-04-29T22:23:11.560Z DEBUG [FILES] CREATED: C:\mediro\test\src\app\components\Card.tsx (1.65 KB)
2024-04-29T22:23:11.560Z DEBUG [FILES] CREATED: C:\mediro\test\src\app\components\Header.tsx (0.41 KB)
2024-04-29T22:23:11.561Z DEBUG [FILES] CREATED: C:\mediro\test\src\app\pages\Data.tsx (2.85 KB)
2024-04-29T22:23:11.561Z DEBUG [FILES] CREATED: C:\mediro\test\src\app\pages\Home.tsx (1.42 KB)
2024-04-29T22:23:11.561Z DEBUG [FILES] CREATED: C:\mediro\test\src\assets\.gitkeep (0.00 KB)
2024-04-29T22:23:11.561Z DEBUG [FILES] CREATED: C:\mediro\test\src\assets\Dynatrace_Logo.svg (2.37 KB)
2024-04-29T22:23:11.562Z DEBUG [FILES] CREATED: C:\mediro\test\src\assets\community.png (9.70 KB)
2024-04-29T22:23:11.562Z DEBUG [FILES] CREATED: C:\mediro\test\src\assets\community_dark.png (9.76 KB)
2024-04-29T22:23:11.563Z DEBUG [FILES] CREATED: C:\mediro\test\src\assets\data.png (5.57 KB)
2024-04-29T22:23:11.563Z DEBUG [FILES] CREATED: C:\mediro\test\src\assets\data_dark.png (8.27 KB)
2024-04-29T22:23:11.563Z DEBUG [FILES] CREATED: C:\mediro\test\src\assets\devportal.png (13.10 KB)
2024-04-29T22:23:11.564Z DEBUG [FILES] CREATED: C:\mediro\test\src\assets\devportal_dark.png (13.73 KB)
2024-04-29T22:23:11.564Z DEBUG [FILES] CREATED: C:\mediro\test\src\main.tsx (0.44 KB)
2024-04-29T22:23:11.564Z DEBUG [FILES] CREATED: C:\mediro\test\tsconfig.eslint.json (0.07 KB)
2024-04-29T22:23:11.565Z DEBUG [FILES] CREATED: C:\mediro\test\tsconfig.json (0.74 KB)
2024-04-29T22:23:11.575Z ERROR Error: Installing the dependencies failed.
Please try to run npm install

2024-04-29T22:23:11.575Z DEBUG [TELEMETRY] Reporting crash
2024-04-29T22:23:11.575Z DEBUG [TELEMETRY] Closing OpenKit connection
2024-04-29T22:23:11.798Z DEBUG [TELEMETRY] Successfully closed OpenKit connection

Dynatrace Advisor
Dynatrace Advisor

Hi @brett_schubach1, from the logs, it looks like the app folders and files were created successfully, and only the dependencies installation failed. I also noticed you ran npm install in C:\mediro where there's no package.json. You need to run it inside the app folder C:\mediro\brett-test-app.

I'm unsure what the issue might be, but running npm install in the app folder could work. If it still doesn't, please check the troubleshooting section regarding proxies and firewalls


Best, Edu.

Hi @SarahFaustmann and @educampver 


It is very strange but I found the install of my old laptop node-v18.18.0-x64 and when I install this version and run it it works 100% barring that it saying it not a supported version but will investigate further as if I install node-v18.20.2-x64  it also fails. I will update here if I find a solution 



I went through these steps and every things outcome was the same as expected into the documentation. 


Featured Posts