cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Looking to upgrade from Dynatrace Managed to SaaS? See how

Uploading error - Unable to upload offline installer bundle on a specific cluster.

Suryanto_1
Guide

On two separate Dynatrace Managed cluster. Using the same offline server installer.

We were able to upload the file to one cluster but not the other cluster via the CMC web console

The server file offline installer size is 1.5GB.

The file couldn't be corrupted if not uploading would have fail on both clusters.


We had done the following.

- Redownload the installer.

- Reboot the cluster nodes.

- Edge private mode. same error.

- Chrome private mode. same error.


While the file is uploading. It states, "waiting for server response" before "Uploading error"

What are the pre-checks or checks it do before it errors. Support says the support archive had no errors!!!

NOTE: We do not have the rights to upload the file manually onto the server itself.


Kindly advice

4 REPLIES 4

Romanenkov_Al3x
DynaMight Pro
DynaMight Pro

Hello and I understand you like no other. 

Unfortunately, in most cases, support recommend directly uploading the archive to the server. If this option is not possible for you, you can try the following:

The root cause of the download fails in third-party utilities that control the network (for example, between two network segments)

If you can talk to the specialists responsible for this - about switching off for a while or adding rules - so you can upload the archive.

 

The connection can also be broken not after reaching a certain amount, but by the amount of data transmitted during the time.

Romanenkov_Al3x_0-1702105892695.png

 

You can try to limit these settings in a browser (for example, chrome) and try to upload the archive. Perhaps 2-3 hours later - instead of 15 minutes - you will upload it, because the network control utilities will not break your connection. I had such a case. Hope this helps.

 

Regards,

Alex Romanenkov

DT_NGINX_ALL_WHITELISTED=1

islam_zidan
Champion

Hello,

Are you trying to use the same package for both clusters? from my previous offline experience, each cluster has it's own packages that could be provided through update mails or Dynatrace support. I believe each package is tailored for the cluster.

 

Thanks,

Islam

Dynatrace Certified Professional - Dynatrace Partner - Yourcompass.ca

Suryanto_1
Guide

 

@Romanenkov_Al3x Thanks for the assistance. Its something with our network using the FQDN. We were able to upload the file by accessing the individual IP of the cluster nodes via the web console. 

@islam_zidan FYI. We can use the same installers across our identical clusters

 

Thanks for feedback, this will help other community members. I am glad that your problem has been resolved.

There were different update packs for different clusters and they did not exactly fit together. But it was on 150-160 versions. 😉

Regards,

Alex Romanenkov

DT_NGINX_ALL_WHITELISTED=1

Featured Posts