cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem with Request Attributes not being seen within Service when configuring "Business Transaction" (Web request naming - Request naming rules)

victor_segovia
Inactive

In our Dynatrace SaaS deployment, we have configured a couple of Request
Attributes and they are working just fine (we can see them working in the
corresponding Services), but when we what to configure a "Business
Transactions" like stated here
https://www.dynatrace.com/blog/track-business-transactions-using-advanced-request-naming-rules/
(Service settings - Web request naming - Request naming rules) we have the
problem that when we want to select a specific Request Attribute to serve as an
additional filter (Add condition) when configuring the “Business Transactions” the
interface is showing us that the selected Request Attribute is "not seen
on Service"; but we have clearly seen that the Request Attribute is being
captured in that specific Service. What could be happening?

3 REPLIES 3

michael_kopp
Dynatrace Pro
Dynatrace Pro

This might just be a timing issue. If the attribute has not been seen for a while, the screen would react that way. Could that be the issue here? You can still define the BT btw, it is just a hint.

Hi Michael, The attribute was being captured since a
while when we configured the "Business Transaction"; also the Attribute
is still being captured right now and nevertheless the issue persist when we
want to edit the already mentioned "Business Transaction" or creating
a new one.

Hi Victor,

I would have to look at it in more detail, I would recommend to open a support ticket with the information about the environment and service in question. I'll take a look then.