cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SLO returned as N/A due to "empty" metric calculation

Stiuzz
Participant

Hi all,

before opening a RFE I would like to understand if there is a way to solve this: We have an application where users can browse several funnels, we created a custom metrics to count the user actions for each funnel and we configured some key request for each funnel that report about problems with the current user action in the funnel. We created a SLO to measure the percentage of ok actions against ko actions using this formula:

 

(CustomMetricResponseTime_CountOfTotalActionInTheFunnel - KeyRequestCount_SumOfTotalKoActionInTheFunnel) / CustomMetricResponseTime_CountOfTotalActionInTheFunnel * 100

 

The problem here is that if, in the timeframe, there aren't any Ko actions the metric for the key user action (KeyRequestCount_SumOfTotalKoActionInTheFunnel) is returned as empty (Not "null" or "0") and for this reason the SLO is reported as N/A (Phylosophically as the measure is a count a "0" should be returned).

I tried to apply several transformation to the metrics (:default(0), :fold, +(1), etc) to obtain a valid value that could be used in calculation but with no result.

Does anyone have a solution for this?

 

Regards

Stefano

4 REPLIES 4

ChadTurner
DynaMight Guru
DynaMight Guru

Depending on if you are a Managed or SaaS customer, Dynatrace SaaS is rolling out a cluster update which contains updates to SLOs. I would recommend reviewing the SLO once you get the latest update 1.229

-Chad

Hi Chad,

where is the solution to this problem? I tried to configure a SLO with version > 1.229 but the issue is still present both in SLO and in calculated metrics, still not able to calculate when a metric result as empty.

Do I miss something?

 

Regards

 

PhilH
Newcomer

I am having the same issue, have you found a solution which works?

wolfgang_heider
Dynatrace Helper
Dynatrace Helper

Hi everyone,

could you please confirm:

The metrics you use were not just created, but already had data.

Just for the timeframe of the SLO there is no data but in the past there was already data?

To find a solution for that (on the product side) I try to find out the best option. Because right after a custom metric was defined (without data stored yet), the metric does not allow any query yet. That would be an explanation - if that is was the case with your SLOs.