cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Datapower Plugin Error - "No connection adapters were found for [our url]"

robert_hamilton
Participant

We are currently using Datapower Plugin Version: 1.089. When setting this up, all configurations are accepted and we get the green checkmark.


However, data never shows, and the logs show the following errors(I've masked the URL):


2019-08-22 17:40:00.072 UTC WARNING [Python][9304997945187610746][][139954624485120][ThreadPoolExecutor-0_0] - [getRESTResult] Failed polling: url.url.com:9090 with domain: default
2019-08-22 17:40:00.072 UTC ERROR   [Python][9304997945187610746][][139954624485120][ThreadPoolExecutor-0_0] - [getRESTResult] No connection adapters were found for 'url.url.com:9090'
requests.exceptions.InvalidSchema: No connection adapters were found for 'url.url.com:9090'

7 REPLIES 7

diego_morales
Dynatrace Helper
Dynatrace Helper

Hi Robert,

Could you please open a support ticket for this? I believe there is a newer plugin version that may address this issue.

Thanks,

Diego



I have updated the plugin to v1.091. Same error is given.


Mike_L
Dynatrace Pro
Dynatrace Pro

What URL did you fill into the configuration? It looks like you forgot to add http:// or https://

Make sure to fill in the full URL to the XML management interface, the default URL is in the display hint.


I have updated the plugin to v1.091. Same error is given.


@Michael L. - when I add https://, I receive

Update failed - Error(not well-formed (invalid token): line 2, column 2) 

What is the full value you are entering?


robert_hamilton
Participant

SOLUTION for others:

Changed the port to 5550 (9090 is the GUI port) and it worked!


Good! It was a two step solution because you had to do both changes you ended up doing 🙂