Showing results for 
Show  only  | Search instead for 
Did you mean: 

Python 2.0 extension Init workspace error


Good afternoon all, I am trying to setup a python 2.0 extension and every time I initialize the workspace I get this error.


2024-04-26T21:23:49.993Z [ERROR][dynatrace-extensions.initWorkspace] Unexpected error: Traceback (most recent call last):
  File "c:\users\aab0142\appdata\local\programs\python\python38\lib\", line 194, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "c:\users\aab0142\appdata\local\programs\python\python38\lib\", line 87, in _run_code
    exec(code, run_globals)
  File "C:\Users\userid\AppData\Local\Programs\Python\Python38\Scripts\dt-sdk.exe\", line 4, in <module>
  File "c:\users\userid\appdata\local\programs\python\python38\lib\site-packages\dynatrace_extension\", line 11, in <module>
    from .sdk.extension import DtEventType, Extension
  File "c:\users\userid\appdata\local\programs\python\python38\lib\site-packages\dynatrace_extension\sdk\", line 85, in <module>
    class CountMetricRegistrationEntry(NamedTuple):
  File "c:\users\userid\appdata\local\programs\python\python38\lib\site-packages\dynatrace_extension\sdk\", line 88, in CountMetricRegistrationEntry
    dimensions_list: list[str]
TypeError: 'type' object is not subscriptable
I have generated new certificates and also published them to dynatrace. I still get the same error. I would also like to add that I am using a Dynatrace Managed Env and had to add the flag "disableSSLVerification". 
Can someone please help asap! Thank you!

Dynatrace Mentor
Dynatrace Mentor

Hi @trevordconsult , 

Can you please try updating to Python 3.10 from 3.8 as that is what is currently used by the Extensions 2.0 framework. 

I got passed that issue and now I am getting this issue? I still cannot seem to init the workspace. 


2024-04-27T15:30:33.867Z [INFO][utils.conditionCheckers.checkDtSdkPresent] Is dt-sdk available? false
2024-04-27T15:30:54.537Z [ERROR][utils.subprocesses.runCommand] {
  "error": [
    "'dt-sdk' is not recognized as an internal or external command,",
    "operable program or batch file.",
Is there a separate command to install dt-sdk? Would this mater if I am running python version 3.11?

Please use Python 3.10 and then install the SDK in your global Python environment. See the docs here to install the SDK via pip : 


Featured Posts