cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

dt-sdk module

Romanenkov_Al3x
DynaMight Pro
DynaMight Pro

Hello

I am trying to start to work with Add-on for VS Code

I want to try "Python extension 2.0"

The dt-sdk python module needs to be available on your machine for this setup to complete successfully. 

Romanenkov_Al3x_0-1691151771596.png

 

Can anyone answer to me how I can get this module?

Romanenkov_Al3x_0-1691151056941.png

Regards,

Alex Romanenkov

 

DT_NGINX_ALL_WHITELISTED=1
13 REPLIES 13

Mike_L
Dynatrace Guru
Dynatrace Guru

Python in Extension Framework 2.0 is currently only available internally. We're planning to talk more about it for external use next quarter.

Mike

Thanks for fast answer. 👍

DT_NGINX_ALL_WHITELISTED=1

Any updates here?

We are planning to launch it around Perform. There is a HOT session there where you can get hands on experience. 

Mike

Awesome news!  Thanks for information.

 

DT_NGINX_ALL_WHITELISTED=1

g_kat
Helper

Hi,

Based on the video released yesterday https://www.youtube.com/watch?v=Qy4Ge8HIzEk it looks like the framework for python data sources and development for Extensions 2.0 is available or about to be. Is there any scheduled announcement or documentation available?

 

Regards,

George

Mike_L
Dynatrace Guru
Dynatrace Guru

It's scheduled for version 1.284 (February). We will release documentation in the January timeframe. It will be similar to this (currently in progress) documentation: https://dynatrace-extensions.github.io/dt-extensions-python-sdk/

Mike

Mike_L
Dynatrace Guru
Dynatrace Guru

GA of custom python extensions has been postponed to OA/AG 1.285, cluster 1.286

Mike

Hi Mike,

That's a bummer...

 

But, I noticed that in the documentation(https://docs.dynatrace.com/docs/extend-dynatrace/extensions20/data-sources/python) the python source is in Preview right now. Is there any other procedure beyond submitting the access form to get preview access?


Regards,

George

Mike_L
Dynatrace Guru
Dynatrace Guru

There is no additional procedure required.

Mike

HI Mike - just to add to the discussion, for Dynatrace managed, does that mean we'll need to wait until our environment hits 1.285/1.286 before this feature set becomes available? (assuming yes?) 

1.286 will be required both for Managed and SaaS.

Mike

Dang, suspected that was the case, but was hoping I was wrong 😊  Thanks as always Mike - much appreciated! 

Featured Posts