cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Host group assignmen

carlos_carreno
Participant

Good afternoon everyone, I need your support in understanding a scenario when I am assigning the host group to a group of HOSTs

I am assigning a host group to a group of hosts via commands:

.\oneagentctl.exe --set-host-group=xxxxxxxx --restart-service

"When checking through this other command, it seems that this feature was indeed assigned to the host."

.\oneagentctl.exe --get-host-group

carlos_carreno_1-1706813402128.png

Despite having assigned it to the host in that order, when I go to the interface to visualize the data, it doesn't appear.

carlos_carreno_2-1706813473001.png

Example of how it should appear.

carlos_carreno_3-1706813501608.png

Additionally, there is a host that appears assigned to this host group, but the command has never been executed on it.

Thank you for your valuable help and guidance. Many thanks.

5 REPLIES 5

dannemca
DynaMight Leader
DynaMight Leader

In my own experience, the host-group, when set after installation, takes a while to reflect in UI.

For how long are you waiting before check the host-group assignment in UI?

Site Reliability Engineer @ Kyndryl

More than 5 hours

Depending on the size of your env, it may take longer, based on my own experience.

But you can confirm if the assignment takes effect checking the list of hosts by hostgroup in UI:

https://docs.dynatrace.com/docs/platform-modules/infrastructure-monitoring/hosts/configuration/organ...

Site Reliability Engineer @ Kyndryl

AntonPineiro
DynaMight Leader
DynaMight Leader

Hi,

It is weird, you can try from Dynatrace UI also, just to compare if you notice differences.

AntonPineiro_0-1706860575650.png

Best regards

❤️ Emacs ❤️ Vim ❤️ Bash ❤️ Perl

Thank you very much for the input. I will make the change through that method, and I hope the host accepts it. In theory, it should work 🙂

Featured Posts