Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issue updating to latest version of iOS sdk

Frequent Guest

I'm seeing this error when I try and update Dynatrace to Previous version didn't show this error.

[!] Can't merge user_target_xcconfig for pod targets: ["Global", "OtherSDK", "Dynatrace", "xcframework"]. Singular build setting EXCLUDED_ARCHS[sdk=iphonesimulator*] has different values.


Dynatrace Champion
Dynatrace Champion

Since the update spans a wide range of agents (8.247→8.265) the most likely change is the dropped support for bitcode done with 8.257 or dropped support of 32-bit architectures done with 8.251 8.249. See supported technologies here:
You probably need to update your project or podfile to no longer use bitcode or 32 bit architectures (which are also no longer supported by apple for app store submission)

iOS help:

Dynatrace Champion
Dynatrace Champion

The error message you are seeing indicates that there is a conflict in the build settings for the Dynatrace SDK and some of the other dependencies in your project, specifically with the EXCLUDED_ARCHS build setting for the iphonesimulator SDK.

This conflict may be caused by a change in the way that the Dynatrace SDK is built or by a change in the build settings of one of your other dependencies. It's also possible that this is a bug in the Dynatrace SDK itself.

To resolve this issue, you can try the following steps:

Make sure that you have the latest version of all of your dependencies installed, including the Dynatrace SDK.

Try removing the EXCLUDED_ARCHS build setting from your project or target and see if that resolves the conflict.

If the above steps do not resolve the issue, you may need to reach out to the Dynatrace support team or the developer community to get more information about this error and how to resolve it. You can also try downgrading to the previous version of the Dynatrace SDK that worked for you and wait for a fix or an update from the Dynatrace team.

It's also worth noting that this error message may not necessarily indicate a problem with the Dynatrace SDK itself, but rather a conflict between it and another dependency in your project. Therefore, it may be helpful to review any recent changes you have made to your project or dependencies to see if you can identify the source of the conflict.


Frequent Guest


I've tried deleting EXCLUDED_ARCHS from my project but not been able to resolve this issue.


Looking at the podspec the offending lines were added in version
"user_target_xcconfig": {
"EXCLUDED_ARCHS[sdk=iphonesimulator*]": "i386"
"pod_target_xcconfig": {
"EXCLUDED_ARCHS[sdk=iphonesimulator*]": "i386"

According to the Cocoapods blog the command should be used with care and not to make assumptions about the build environment and this is what is happening in this scenario. The issue described on this page is exactly what is occurring for me.

i386 is 32-bit architecture which is no longer supported, even by Apple - so removing that from your project might be the faster workaround.
we can take a look into our usage of user_target_xcconfig, but for that we would need a support ticket with a project to reproduce this issue as we won't change a podspec working for 99.9% without any reproducer problem.

iOS help:

Hi Patrick,

I've opened a support ticket and included a sample project demonstrating the issue.

Many thanks for your help


Featured Posts