Showing results for 
Show  only  | Search instead for 
Did you mean: 

Multidimensional analysis - no data for short interval -



I have a problem with multidimensional analysis, im using a request count metric, with some filter. When i set the time interval to 6 hours or more i can see data fine, but if i try to lower the interval, i got the message that "no data matches your filter setting", but in the long intervall settings i can clearly see there is data.

My question is why DT not showing me data if i try to look for a short interval?


Dynatrace Advisor
Dynatrace Advisor

Hi Akos,
What is exactly the Metric expression used ? can you attach some screenshots please ?
For me , all depend on your timespan (datapoints per min) and also about your Metric expression.

Hey, here are some images , with different time frame, and with the same filters.

Dynatrace Advisor
Dynatrace Advisor

Here you are using MDA chart (Multidimensional Analysis).

AFAIK, actually you are using "Trace and request data" , namely given that when you use 20-40 min timeframe, your interval granularity is at 20 sec ... so need to check your infra disk capabalities.
Unlike to "more than 1 hour" timeframe , where your interval granularity is 1 min , so enough for generating your datapoints !
By default in order to capture your datapoints, need to have at least 1 min of resolution!

You can accomplish this via Metric selector into Data Explorer , so via calculated service metrics.
"Trace & request data" VS "Metric data"

Another important info :
Be aware of using MDA, the data is stored into "Transaction storage" filesystem" wich is less relevant/accurate looking retention data storage and depend on your space disk capacity. Unlike to metrics storage (Cassandra) , where the use of Metric chart via Data Explorer is accurate and use for Timeseries.
To achieve this, I recommend to create "calculated service metrics" , then you can enjoy it via Data Explorer tile.


Unlike the Data explorer, multidimensional analysis uses trace and request data, not metric data, so values on multidimensional analysis charts might differ from values on custom charts.


Actually i used this fuction that i mentioned in the first post, the short interval search almost everyday, not for the chart, but for the data below the chart.

Btw on the attached image (2hours.png) we see data, but sometimes, it has only on 6 hours or wider time interval.

What happens when you go to the "Distributed Traces" list with the same filters and same timeframes.
Is it also only showing traces in the long timeframe and not in the short one?

I tried now, but I got the same result like in the MDA

Please gather the links and talk with support, they can forward everything to the right DEV team then they can best investigate by looking at the data. IMO this should not happen.

Featured Posts