Showing results for 
Show  only  | Search instead for 
Did you mean: 

My ActiveGate are now displayed with their IP address


Hi all

I noticed after migrating my ActiveGate from 1.215 to 1.225 that they are now displayed in the ActiveGate list with their IP address instead of their usual name (FQDN). Am I the only one having this issue ?

This is really not easy to manage.

Is there anything to configure to change this behavior ?






I had an issue like this - might be related.  On my Linux AGs, I had an entry in the hosts file referencing to the hostname.  Once I removed that entry (and possibly rebooted the AG, can't remember) it switched back to FQDN in Dynatrace.

I'm going to see if our Admin can try this fix.   We have had the same problem for 6+ months.  Asked or Guardian and they couldn't figure it either.   It occurred when we created a new server (switch to a different Linux OS flavor). We killed the old machine then built a new one with the same hostname.   It instead switch to IP and haven't been able to fix it since. We tried many different solutions.


Will post back once we try this. Hopefully this fix works because our next step is to just destroy it and build a new machine with a new hostname.

HigherEd worked. Thank you for posting this solution.


DynaMight Champion
DynaMight Champion

I have the same issue but on Windows-based ActiveGates. Checked the hosts file, nothing in there that could cause this. Any other ideas?

Hi @andre_vdveen 

Had the same problem with Windows AG.

After altering the entry in hosts to the desired name and reboot the windows, nothing change i.e. from dynatrace UI the name didn't changed, only after restart of the AG service, the name also changed in dynatrace UI.



dynatrace certificated professional - dynatrace master partner - Matrix Soft Ware Division - Israel

Hi @Yosi_Neuman thanks, mine sorted themselves out in the meantime, without any interference from my side. There was a version update since my first post, so perhaps something was fixed between versions.


I encountered the same issue after migrating our ActiveGate from an On-Prem virtual environment into a Cloud environment.   I had to do the following in order for the FQDN to be displayed on the "ActiveGate List".

1. Update the /etc/hosts file by replacing the old IP address with the new.

2. Restart the ActiveGate by executing the following command.

systemctl restart dynatracegateway 

DynaMight Guru
DynaMight Guru

In my case, I have a client where the names and IPs keep switching back and forth.

Going to check the hosts file.

Antonio Sousa

Frequent Guest

I had similar issue. I recently installed several ActiveGates in Azure. All my Windows ActiveGates are showing IP as name instead of hostname. Open ticket with Dynatrace support but no solution. Somehow one of these ActiveGate changed its name to hostname after 2 or 3 weeks. But others are still IP. Linux ActiveGates do not have this issue.

Featured Posts