Showing results for 
Show  only  | Search instead for 
Did you mean: 

OneAgent doesn't communicate with ActiveGate


Hi there,


A few weeks I found out that I was not receiving data from hosts without internet connections, and I discovered that all OA´s are communicating directly to my Saas environment(the ones that have internet connections).


PS: ActiveGate is up and in the same Network_Zone but I can´t find out the problem.




Can you try to run a telnet command from the host with OA to the AG?

A simple 

telnet ${activeGateIP} 9999 

Can do the trick, if it hangs then your activegate is not reachable by the host where the oneagent is working. Do you know if there is a firewall between the oneagent and the activegate?


I ran the command:

telnet ${activeGateIP} 9999 

its shows that was unable to connect to remote host: Connection timed out

I´ll try to reach the Infra guy to open this port on our firewall to see if its work...

Hi, @MariusNicolae i opened the port:9999 on my firewall and still the same!!! im out of option right now.

Hi Walter,


Can you confirm now that the telnet from the OA host is working?

Can you try to run

traceroute -T -p 9999 ipAG

And confirm if this is also working? Make sure that the connection is possible now and maybe try to restart the oneagent

I did restart the one agent(oneagentctl --restart-service) before and still not working

traceroute to ipAG (ipAG), 30 hops max, 60 byte packets
1 * * *
2 * * *
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *
8 * * *
9 * * *
10 * * *
11 * * *
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *


Hi Walter,


You need to use your activegate ip, not literally "ipAG"

Can you do that with your activegate ip?


Best regards.

@MariusNicolae i used the AG ip adress, i just masked here with "ipAG" just to show what the result was!!!

Hi Walter,


Well in that case it doesn't look like the activegate is reachable by the host on port 9999/tcp, are you sure the communication from the host with oneagent to activegate on port 9999 in tcp is allowed by the network team?


@MariusNicolae it worked before, after that we had a network problem from supplier, then few weeks ago i lost those connections from OA's to AG. Yesterday i asked the infra-team to enable port 9999 on our firewall and didn't fix.

Hi @Walter2,


One of the possible reasons could be that OneAgent was installed before ActiveGate was available in the environment and after OneAgent lost internet access he could not have the connections endpoints list refreshed by the server.


Try to run oneagentctl --get-server on OneAgent that doesn't have a connection to the cluster to check if desired AcitiveGate is on the list of connection endpoints


You can use oneagentctl --set-server to set the proper endpoint.




Hi @TomekRybczynski 


I ran oneagentctl --get-server on OA's that doesn't have connections to the enviroment AG and the AG is on the list of each one (5 hosts).

Dynatrace Champion
Dynatrace Champion

Hi, could you please check the listening port services of active gate server. The best possible way would be take access of active gate server and run a net stat command to check the listening port for services. This will confirm if the active gate are up and running port no. Once thats is done you can perform a self curl -kv ip:port to verify the curl output. Similar output should be received at OA installed server.


It Helped me to check the AG server firewall and added a new rule to enable entry connection on port 9999 and is working like a charm😅. Was focusing on something to complex, and end up to be something small... THANK YOU GUYS FOR THE HELP
@MariusNicolae @TomekRybczynski 

Featured Posts