Showing results for 
Show  only  | Search instead for 
Did you mean: 

Process is ready to be monitored, waiting for injection status...


Hi community,

i have some Linux hosts monitored, but, in "Deployment Status" i see that these hosts have a "Process isn't monitored" message in the details. The complete message is Process is ready to be monitored, waiting for injection status... and it has been present for several hours.

I tried to disable and re-enable automatic deep monitoring, disable and re-enable process monitoring and check for logs, but i haven't solved the issue. I don't think that a restart can solve it, because warning message doesn't mention a restart required to enable deep monitoring, but i'll try it in any case.

What is the issue's root cause and how to solve it? Thanks to all answers.



DynaMight Guru
DynaMight Guru

In general when you enable and disable deep monitoring, to have change you should restart process. Did you try download support archive from host that contains process and check there? Probably there is some issue during instrumentation. In general OneAgent have watchdog process dat waits for collected data and sends them to main OneAgent process. If this watchdog doesn't receive anything, you may have such communicatie as you see. In general in such cases restart may help, but it's interesting why it's happened.


Regards, Sebastian

Thank you for your answer, i'll try to restart hosts.


Featured Posts