Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to download using monaco v2


Hi, I'm trying to run download using monaco 2.0.0 but it gets hung after the message "INFO Resolving dependencies between configurations".  This generates a really high CPU load on the server this command is run but doesnt progress. Didn't had any issue when running monaco 1.8.9 on the same server to download. Tried using both with a manifest.yaml file and also by specifying the url option with the same result. Any help is appreciated.


DynaMight Guru
DynaMight Guru


Are you following this?

Could you paste which command are you using to download configuration?

Best regards

❤️ Emacs ❤️ Vim ❤️ Bash ❤️ Perl

I'm using monaco version 2(not 1.8.9) for linux. Running the following command(same result whether I export NEW_CLI or not)

monaco download --url https://{environmentid} --token dynToken
and I export my token as dynToken. 

(With monaco 1.8.9 I can access and download using the same token. However I was advised to use version 2 by Dyn Support for deployment testings. So trying to get the download working first with v2)



I can run the same command successfully if I specify "--only-api" but get stuck if I don't specify or use "--only-settings". However with --only-api option it doesnt download all the configuration in Dynatrace.


I am using Monaco version 1.8.9 and normally create a "environments.yaml":

 - name: "test"
 - env-url: "https://{environmentid}"
 - env-token-name: "TEST_TOKEN"

I set environments variables (in Windows):

  • $env:NEW_CLI=1

And I execute command “monaco download --environments=environments.yaml”. It will download all APIs configuration to that environment.

If you want only a specific environment defined in YAML file or a specific API, you can use these parameters "monaco download -e environments.yaml -s test --specific-api synthetic-monitor"

Best regards

❤️ Emacs ❤️ Vim ❤️ Bash ❤️ Perl

Featured Posts