cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Upgraded JRE Version for Synthetic ActiveGate

sivart_89
Advisor

Our ActiveGates were flagged in a vulnerability report for having an outdated JRE version in both /opt/dynatrace/gateway/jre/bin (version 11.0.19) and /opt/dynatrace/synthetic/jre/bin (version 17.0.7). The upgrade to version 1.227 for our ActiveGates fixed things for /opt/dynatrace/gateway/jre/bin (release notes below) but I am still seeing version 17.0.7 in /opt/dynatrace/synthetic/jre/bin.

How can we update the JRE in the synthetic directory for our synthetic ActiveGates?

https://docs.dynatrace.com/docs/whats-new/release-notes/activegate/sprint-277#jre-upgrade

16 REPLIES 16

radek_jasinski
DynaMight Guru
DynaMight Guru

Hi @sivart_89 

You do not have the option to manually update the Java version for ActiveGate. The answer I got once from support:
You can't do that on your own. We need to deliver java with our code. Good news is that we are going upgrade java to 8u202 in v168.

I recommend you to create a ticket in support.

Radek

Have a nice day!

Thank you for the information.

Mizső
DynaMight Leader
DynaMight Leader

Hi @sivart_89,

I had the same issue. I have just received an answer from support.

"We will update the Java to 17.0.9 in ActiveGate 1.281. Expected release date is mid of January."

 Best regards,

Mizső 

Certified Dynatrace Professional

Hi @Mizső thanks for the information here. I forgot to follow up with this one. I ended up creating a support ticket for this on 11/2. Support told me this will be in place late November with AG 1.279. We are on SaaS though so I wonder if that is the difference with what you were told? Hopefully we are still on track for 1.279

Mizső
DynaMight Leader
DynaMight Leader

Hi @sivart_89,

It is a fresh response from Support...maybe ther will be one month delay...

Best regards,

Mizső

Certified Dynatrace Professional

Thank you for info. We still have to wait😅

Radek

Have a nice day!

Suryanto_1
Guide

AG 1.281 is release. It doesnt appear to have the fix or did i misread it? Kindly advice

https://docs.dynatrace.com/managed/whats-new/release-notes/activegate/sprint-281

Mizső
DynaMight Leader
DynaMight Leader

Hi @Suryanto_1,

I am gonig to check it after the managed 1.282 roll out at the 1.281 AG.

Best regards,

Mizső

Certified Dynatrace Professional

Mizső
DynaMight Leader
DynaMight Leader

Hi @Suryanto_1 ,

Original java issue has been solved in AG. Synthetic jre upgarde has been done from 17.0.7 to 17.0.8

Mizs_0-1706173468799.png

Best regards,

Mizső

Certified Dynatrace Professional

Thats good to know.  However

1. Release note didnt state it was taken care of (which usually an evidence for customers)

2. When I log case with support they also mention say fix in the upcoming AG 11.283 release with JRE 17.0.9

Hopefully info can be better in sync to reduce confusion and inconvenience

Suryanto_1
Guide

Also is the rollout correct. We are getting AG 1.282 instead of 1.281.

The installer we downloaded is ActiveGate 1.282.18.20240111-043946

As in cluster server are even number while ActiveGate are odd number.


Another thing to point out from the AG 1.281 release note

RHEL 8.9 is supported on the server but not on the ActiveGate

 

I'm checking on the AG version. You're correct I wouldn't expect 1.282 to be available in Production. 

Does the upcoming 1.283 support RHEL 8.9 and fix the JRE vulnerability?

I can't see any plans for the Synthetic AG to be supported in RHEL 8.9.

Support says it would be latest support by AG 11.285 release sometime in March 

Interesting. I can see that should be the case for a vanilla ActiveGate but I thought you were interested in Synthetic. For Synthetic, I can't see this being worked on. I only see this for standard AG. 

Featured Posts