cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Vmware Dynatrace Unknown host

gabriel_gomez
Participant

Hello, I am carrying out the Vmware configuration and I get the following error when I perform the connection test-

gabriel_gomez_0-1697756225618.png

The validations are:
In the activegate I can view the vcenter from the browser.
The activegate has the Vmware extension enabled.

gabriel_gomez_1-1697756339883.png

 

12 REPLIES 12

Taylor-Sanchez
Dynatrace Advisor
Dynatrace Advisor

Hi @gabriel_gomez ,

Couple of questions to help troubleshoot this if possible:

1. Do you know if you currently have some sort of a proxy between your vCenters and Dynatrace?

2. With the ActiveGate that you have configured, do you have multiple? If you do, do you know which ActiveGate this specifically is going through?

Reasoning for asking these questions are for troubleshooting purposes. The best case scenario here if you are still encountering this problem would be to narrow down which ActiveGate you are using for these extensions and gather the logs from there to see what behavior this is emulating. 

Best Regards,

Taylor Sanchez

Dynatrace ACE Services Consultant

1. Do you know if you currently have some sort of a proxy between your vCenters and Dynatrace?

R// We do not have a Proxy

2. With the ActiveGate that you have configured, do you have multiple? If you do, do you know which ActiveGate this specifically is going through?

R// I only have the agents that point to that activegate

gabriel_gomez_0-1697761852486.png

 

Do you have any suggestion?

islam_zidan
Champion

Hello,

Try to connect with the IP address instead of hostname.

 

Thanks,

Islam

Dynatrace Certified Professional - Dynatrace Partner - Yourcompass.ca

I have done it both ways and the same error appears.
When I open the browser in the activegate I enter the name and the vcenter opens. When I make the connection through Dynatrace it doesn't work and I get that error

islam_zidan
Champion

can you share a screenshot of the configuration page in Dynatrace

Dynatrace Certified Professional - Dynatrace Partner - Yourcompass.ca

This is with IP

gabriel_gomez_0-1698156005844.png

This is with Name

gabriel_gomez_1-1698156129051.png

I have to put the https because when I enter the operating system and open the browser to enter the vcenter it asks me to enter the htpp

islam_zidan
Champion

can you try only bogivcsa01.arp.fs.net without /ui or https://

Dynatrace Certified Professional - Dynatrace Partner - Yourcompass.ca

andre_vdveen
DynaMight Champion
DynaMight Champion

Hi @gabriel_gomez, I think what @Taylor-Sanchez is asking is whether you have only one ActiveGate or multiple ActiveGate deployed at the moment. If multiple, you'll have to determine which one is being used for the VMware integration, assuming they're all enabled for VMware integration, which they should be since that's the default.

 

The documentation is clear on not adding the http:// or https:// prefix, so please take that off as it won't work when the protocol prefix is added.

 

Unknown host indicates name resolution issues to me, or that the host simply does not exist on the network. To verify hostname resolution is working, run the command below from the ActiveGate, replacing <target_FQDN> with your vCenter or ESXi hostname and <DNS_server_IP> with a valid DNS server IP in your network. If the hostname of the vCEnter/ESXi host resolves, then try the curl test; if it does not resolve, then the ActiveGate from which the connection to vCenter/ESXi host is made, is not working due to e.g., invalid DNS settings.

nslookup <target_FQDN> <DNS_server_IP>

 

You said the connection from the ActiveGate to vCenter was tested via the browser and it works - have you confirmed there are no proxy settings set in the browser? I'd still do a traceroute or ping test at O/S level, assuming ping is allowed, to confirm that the connection can be established outside of the browser. You could use curl and try it using the hostname, the FQDN, and the IP address:

curl -v https://your_vCenter_or_ESXi_host

Also, test connection from the vCenter to the ActiveGate for completeness sake, since the vCenter must be able to send the data back once the connection is established:

curl -v https://your_AG_IP:9999/communication

 

PS: I was able to reproduce the problem by configuring a connection to a non-existing host e.g., the IP address I used, does not exist on our network, or is not in use. I also get the Unknown host error, so perhaps triple-check the hostname/FQDN/IP address you used...typos do happen! 😉 

@andre_vdveen  Hi

I think what @Taylor-Sanchez is asking is whether you have only one ActiveGate or multiple ActiveGate deployed at the moment. If multiple, you'll have to determine which one is being used for the VMware integration, assuming they're all enabled for VMware integration, which they should be since that's the default.

R// I only have 1 active gate  operating system is Windows

2. Thedocumentationis clear onnotadding thehttp://orhttps://prefix, so please take that off as it won't work when the protocol prefix is added.

gabriel_gomez_0-1699647644457.png

3.

nslookup <target_FQDN> <DNS_server_IP>

gabriel_gomez_1-1699647949126.png

4.

curl -v https://your_vCenter_or_ESXi_host

gabriel_gomez_2-1699648009567.png

5

curl -v https://your_AG_IP:9999/communication


 

gabriel_gomez_3-1699648069875.png

Make this change to unsubscribe the proxy in the custom properties
[http.client]
proxy-off = true
and all the communication between the agents and the activegate went away, the activegate stopped working

Also additions this
[vmware_monitoring]
vmware_monitoring_enabled = true

Have you written to support in this regard to confirm that the configuration is correct?

Have a nice day!

Based on the outputs of those commands, you seemingly have a network connectivity problem between the vSphere and ActiveGate, which you'll need to resolve.

Featured Posts