Showing results for 
Show  only  | Search instead for 
Did you mean: 

modern nginx/openresty instrumentation with oneagent


Hi! Is there a workaround or plan to get newer builds of Openresty (Nginx) supported by oneagent? They are based on newer flavors of Nginx which are generally supported, but the instrumentation fails. currently i have to pin my openresty deployment to a very old version (Version - 17 November 2016) in order to get instrumentation


Dynatrace Mentor
Dynatrace Mentor

Hi Rick, I think I'm currently facing a similar issue. Instrumenting Kong (based on Openresty) is failing. I have a ticket open for that. You are saying that using an older version of the OneAgent worked to instrument OpenResty?

no, i had to use an old version of openresty to get the oneagent to work. it's funny our kong instances are definitely good (we are on 0.10.3 i think)

Got it, thanks Rick.

The problem we are facing is with Kong Enterprise Edition 0.34-1v.

It is using Openresty version

Hi, did you solve that? If only I run ENTRYPOINT script (docker) with nginx/kong I get failure, running w/o dynatrace waraper script - application works as it should.


a lot of lines cut
2022-07-22 16:54:43.061 UTC [00004d02] info [native] Registering agent via core module hook (default; custom array registration viable as well)
2022-07-22 16:54:43.061 UTC [00004d02] info [native] Nginx successfully instrumented
2022-07-22 16:54:43.062 UTC [00004d02] info [native] Agent successfully loaded from '/opt/dynatrace/oneagent/agent/bin/'

Error: could not prepare Kong prefix at /usr/local/kong: could not find OpenResty 'nginx' executable. Kong requires version to

Run with --v (verbose) or --vv (debug) for more details

bash-5.1# /usr/local/openresty/nginx/sbin/nginx -v
nginx version: openresty/

So supported nginx version is installed and used, but add DT wrapper script (oneAgent) to this equation and you have a failure...


bumping with enough characters to ok there we go

DynaMight Legend
DynaMight Legend

Rick, have you had any progress with this? Here is the list of supported Tech and versions: If your technology or version is not supported, you can always put in a RFE and.or monitor the technology via agentless monitoring.

Granted this is an old thread, so were you able to monitor the technology? Did you have to go the Agentless route? do you have any tips/feedback for users who are looking to monitor the same thing?


Featured Posts