cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem occurred configuring project ':capacitor-cordova-android-plugins'.

carlos_carreno
Contributor

Good afternoon everyone,

With the objective of monitoring a mobile application for iOS and Android, the procedure was carried out using the "Dynatrace Cordova plugin" according to the Dynatrace guide. However, during compilation, the following error is thrown: "A problem occurred configuring project ':capacitor-cordova-android-plugins'.


> Could not resolve all files for configuration ':capacitor-cordova-android-plugins:classpath'.
> Could not find org.jetbrains.kotlin:kotlin-gradle-plugin:1.7.1.
Searched in the following locations:
- https://dl.google.com/dl/android/maven2/org/jetbrains/kotlin/kotlin-gradle-plugin/1.7.1/kotlin-gradl...
- https://repo.maven.apache.org/maven2/org/jetbrains/kotlin/kotlin-gradle-".

Currently, the project has the following libraries:
Ionic project version: v5.4.16
Version of the Dynatrace Cordova package installed (latest): @dynatrace/cordova-plugin": "^2.291.1".

 

Would appreciate your help.

1 REPLY 1

Thomas_Wirth1
Dynatrace Champion
Dynatrace Champion

Version 1.7.1 does not exist for the Kotlin Gradle plugin. I assume version 1.7.10 should have been used.

We assume that this problem is not related to Dynatrace, because the Dynatrace Cordova plugin does not add this dependency. Our assumption is that a wrong version was specified in one of your build.gradle files.

Featured Posts