Showing results for 
Show  only  | Search instead for 
Did you mean: 

easyTravel Documentation and Download

Community Team
Community Team

easyTravel - One step to happiness  

easyTravel is a state-of-the-art demo application for Dynatrace. It helps you evaluate or showcase Dynatrace with a realistic heterogeneous multi-tier web application.



easyTravel provides a web portal that allows users to log in, search for journeys to various destinations, select promotional journeys directly that are offered, and book a journey using credit card details.


Additionally, a Business-to-Business (B2B) web portal for travel agencies is provided where travel agencies can manage the journeys that they offer and can review reports about made bookings.

easyTravel is a multi-tier application implemented in .NET and Java. The starting of the various tiers and the enabling/disabling of different problem pattern plugins is done via a separate easyTravel Launcher.


The Launcher allows the user to conveniently switch between different demo scenarios. Each scenario can define load scripts and certain problem pattern plugins that are enabled. The scenarios can be modified or extended by changing an XML file. This is useful when giving demos and allows you to focus on problem areas that are particularly relevant for a specific demo.


Search and book a journey on the easyTravel web frontend with a realistic multi step booking process.Search and book a journey on the easyTravel web frontend with a realistic multi step booking process.         Start all the tiers of easyTravel and enable architecture and performance flaws by selecting a pre-configured scenario.Start all the tiers of easyTravel and enable architecture and performance flaws by selecting a pre-configured scenario.



Check latest published version here:

Linux installer 
Windows installer 

easyTravel security updates

Please see this page for the security updates in easyTravel: easyTravel security updates.


Install easyTravel


  • If you already have easyTravel installed, uninstall it.
  • On Microsoft Windows
    • IIS (Internet Information Server) installed and working if you want to use easyTravel procedures via IIS
    • .NET Framework 2.0 or higher if you want to use/demo  .NET features of Dynatrace
  • On Linux - use one of the supported distributions, which are: 
    • debian 9
    • debian 10
    • ubuntu 18
    • ubuntu 20
    • ubuntu 22
    • centos 7
    • centos 8

Installation steps for Windows

  • Download easyTravel (see above)
  • Run the installer

Installation steps for Linux

  • Download easyTravel (see above)
  • execute "java -jar dynatrace-easytravel-linux-x86_64.jar"
  • execute "/bin/bash" in <easytravel install dir>/resources directory. NOTE: you need root privileges to run this script.


Run easyTravel


  • run "easyTravel Configuration UI" from Windows Start Menu OR
  • run <easyTravel-InstallationDirectory>\weblauncher\weblauncher.cmd
    Weblauncher will be accessible at http://localhost:8094/main


  • run <easyTravel-InstallationDirectory>\weblauncher\


  • Click on the scenario you want to run (e.g. "Standard")
    Now all the tiers of easyTravel are starting up and when you run it for the first time easyTravel will populate the internal database with a good amount of test data - so this may take a minute or two for the first run.
    To generate heavy load on the application go to the easyTravel launcher and switch to the Black Friday Scenario by clicking on the link "Black Friday".




Install OneAgent


tomasz_wieremje_1-1687262186452.pngYou should disable monitoring of launcher (com.dynatrace.easytravel.launcher.jar easyTravel (x*)) and weblauncher (com.dynatrace.easytravel.weblauncher.jar easytravel-*-x*) processes. Otherwise, there will be no connection between application and services. 

  1. Edit a process.tomasz_wieremje_2-1687262186452.png


Disable process monitoring.




Connecting easyTravel to Dynatrace (SaaS and Managed)

tomasz_wieremje_4-1687262186453.png Only needed if you need mobile app traffic.

You have to edit "C:\Program Files\Dynatrace\easyTravel (x64)\resources\"

Set following configuration properties for SaaS:

config.apmServerDefault = APM


When connecting to the Dynatrace Managed server:

config.apmServerDefault = APM




➡️Error during installation: "Error writing to file: UltiDevCassiniHttpRequestProcessor2.0.dll. Verify that you have access to that directory."

Ensure that Microsoft IIS (Internet Information Server) is installed and working and ensure that .NET Framework 2.0 or higher is installed.

➡️Apache HTTPD does not start, error "An operation was attempted on something that is not a socket" in error.log

This indicates that some other installed software interferes with socket network calls. A workaround is to add the following additional setting to the Apache HTTP config file at <installation_location>/apache2.2/plain_conf/plain_httpd.conf


For details, see the Apache Documentation.


➡️Internet Explorer 9 displays some pages incorrectly in compatibility mode

If Internet Explorer displays some pages with incorrect layout, (e.g. text-fields in one of the login screens are displaced or login box is displayed behind other content), you likely run Internet Explorer in "compatibility mode", where it simulates an Internet Explorer 7.

You can disable compatibility mode by clicking the blue "broken page" icon so that it is displayed in gray again.



➡️.NET Applications do not fully start on an Windows XP or Windows Server 2003 instance

See easyTravel on Windows XP and 2003 for a detailed description of the problem and a number of possible workarounds.

➡️.NET Applications do not start - "An attempt was made to access a socket in a way forbidden by its access permissions"

This problem is likely to be caused by IIS running dotNetBackend and dotNetFrontend thus blocking the port the backend is trying to use. The frontend just gets assigned another port.

➡️"Error while checking Credit Card - The system cannot find the file specified"

In 3.5.1 this can indicate that you need to update your Agent to the latest version in order to make ADK/C++ instrumentation work correctly. I.e. you should at least install the Update "April 2011", make sure to also update the agent dlls as well.

If you rather stay with the current agent and would like to work around this problem you can go to the Problem Patterns tab in the easyTravel launcher and deactivate the plugins “NamedPipeNativeApplication” and “NamedPipeNativeApplication.NET” and instead activate “DummyNativeApplication” and “DummyNativeApplication.NET”


➡️.NET Applications running slow on Firefox

If the .NET-Application seems to be running slow in Firefox on localhost, try using the ip-address instead or add localhost to network.dns.ipv4OnlyDomains in the Firefox configuration, enter the following in the address bar "about:config" to access Firefox configuration.


➡️iOS easyTravel App does not install

This problem is likely to be caused by multiple network interfaces (e.g. from VMWare) on the easyTravel host. To override the host auto detection for the iOS App download configure appleMobileHost in C:\Program Files (x86)\dynaTrace\EasyTravel\resources\ to the IP address of your easyTravel frontend.


➡️iOS easyTravel App does not install due to connection error

You are getting an error like "Cannot connect to x.x.x.x" or "Cannot install applications because the certificate for x.x.x.x is not valid". This problem is caused by apple by requiring an SSL-Connection to install the app via direct link. You have install the self-signed SSL-Certificate, which can be found in the “iOS App Installation”-section on the "About"-page.



The overall architecture consists of:

  • Two Java processes providing the Customer Frontend and the Business backend server
  • Two .NET processes providing the B2B Frontend and the Payment backend server
  • A C++ application which receives credit card numbers via IPC/Named Pipe and simulates verifying the number against a third party provider.
  • A Launcher GUI which allows to control the processes and also hosts the Java Derby Database (unless some other RDBMS is configured)
  • A Java Derby Database for storing the travel data (can easily be replaced with other JDBC databases)
  • A MS SQL Server Compact Edition Database for storing payment data
  • Optionally an Apache Web Server instance for load balancing



Memory usage

Estimated main memory usage of default scenario, measured as "process private bytes" on Windows OS:





Launcher (includes Java DB)



Customer Frontend



Business Backend



Credit Card Authorization



Payment Backend



B2B Frontend







Demo Scenarios

The easyTravel Launcher starts up all the processes for the different tiers and also allows a user to enable/disable different problem patterns - known as plug-ins. A configuration of running processes and plug-ins is called a scenario.

In order to focus the demo to the interests of the audience, the scenarios are grouped. By default the easyTravel Launcher offers two scenario groups:

  • UEM
  • Production

Sometimes the default scenarios and groups may not fit your needs. Maybe your audience is not interested in .NET or you want to enable a certain plugin to demonstrate special Dynatrace capabilities. In this case, you have the possibility to set up your own scenarios and groups.


Defining Custom Scenarios

On the first startup of the easyTravel Launcher a default scenario configuration file is created. The scenarios.xml file can be found in USER_HOME\.dynaTrace\easyTravel <version>\easyTravel\config. In order to customize your scenario setup you can edit this configuration.


Because the easyTravel Demo Application and consequently the default scenario configuration may change in further versions, your customized file might be replaced by a new configuration file after an update. The old configuration file is backed up in the original directory.

Since easyTravel for 4.2, you can put your scenario-definitions in a file userScenarios.xml in the config directory and thus avoid this overwriting.


Scenario File Structure

The scenario.xml consists of nested group and scenario tags. The following excerpt shows a common structure:


<group order="1" title="Group Title">
  <scenario enabled="true" order="1" title="Scenario Title">
    <description>Scenario Description</description>
    <procedure id="inprocess DBMS" order="1"/>
    <procedure id="database content creator" order="2"/>
    <procedure id="business backend" order="3"/>
    <procedure id="customer frontend" order="4"/>
    <procedure id="credit card authorization" order="5"/>
    <procedure id="payment backend" order="6"/>
    <procedure id="b2b frontend" order="7"/>



The procedure elements describe the tiers of the scenario. The order attribute of the group and scenario elements define the sequence they are listed in the easyTravel Launcher. The order attribute of the procedure elements defines the startup sequence of the tiers.


Customization Example

Let's assume we want to define a new group with a single scenario. The scenario should run without B2B Frontend and the "SmallMemoryLeak" plugin has to be enabled in order to simulate a memory leak:


<group order="1" title="Example Group">
  <scenario enabled="true" order="1" title="Example Scenario">
    <description>This is an example scenario</description>
    <procedure id="inprocess DBMS" order="1"/>
    <procedure id="database content creator" order="2"/>
    <procedure id="business backend" order="3">
      <setting name="SmallMemoryLeak" type="plugin" value="on"/>
    <procedure id="customer frontend" order="4"/>
    <procedure id="credit card authorization" order="5"/>
    <procedure id="payment backend" order="6"/>



Settings on Procedure Level

Procedures support a few specific settings and additionally allow to override any of the global properties that you have in the file.

Specific settings are available for the following types of procedures:

  • BusinessBackend or PluginService: Enable/Disable plugins as part of a scenario as well as define on which host a plugin is active (if you have multiple instances of a procedure-type running on multiple hosts)
<setting name="DatabaseCleanup" type="plugin" value="off"/>
<setting name="DummyPaymentService" type="pluginhosts" value="dynaday13fall" />
  • Ant Procedure: Set details of Ant-Execution (look at existing scenarios for examples)


Setting global properties on procedure-level via type="procedure_config" only makes sense if you have multiple procedures of the same type and want to set different settings for these or if you use multiple scenarios and one of them requires different settings. Otherwise it is probably easier to specify them in the global property file, ideally in a in the C:\Users\...\config directories.



Questions? Comments? Add them below!

Keep calm and build Community!


Hello Links to download EasyTravel is returning a error page.

Dynatrace Enthusiast
Dynatrace Enthusiast

Hi, another method that worked for me was installing the new version for Linux easyTravel with Docker. A full tutorial can be found here.

Dynatrace Champion
Dynatrace Champion

I am with @crazlaz 
Links to download and also to readme.txt are not working, Linda. Please check and update the latest ones. That would be great to share the post with everyone. 

Love more, hate less; Technology for all, together we grow.


Hi, I am also triying to download EasyTravel and once I try to access the links it gives and error page.

Dynatrace Helper
Dynatrace Helper

The download links should work again 😉


Would we put Customer Frontend, Business Backend, and Business Database components into different servers?  How will we update the application configurations please?



Hi, I've tried to run easyTravel on Raspberrypi 4 with Ubuntu 22.04. The installation process was successful but I was not able to run it because of an error:

sudo ~/easytravel-2.0.0-x64/weblauncher/
/home/ubuntu/easytravel-2.0.0-x64/weblauncher/ 13: ../jre/bin/java: Exec format error

Can easyTravel be deployed on Raspberry Pi? Did you have the same issue?

Dynatrace Champion
Dynatrace Champion

Yes it should work irrespective of its underline hardware until you are running the supported OS and the proper supported execution command for that respective OS.



Hi, I am trying to start the application on CentOs Linux 7 hosted on AWS(noGUI). Getting an error :

WebLaunche WARN [DocumentStarter] Exception occurred while opening URL: http://localhost:8094/. Exception: Cannot run program "firefox": error=2, No such file or directory


Can anyone plz provide a solution for this?

Hi... Can it be that it is a CentOs without UI only terminal? There is no Firefox installed and can not be used.

yes. Is there any way to start the app?

As far as I know a GUI is required to run and configure the app. Unfortunately I don't know a workaround (if any exists) to launch the app without a browser.

You can run the app by executing the script located in the root directory, but no configuration options are available if you use this method.


What I have seen is that no browser traffic is generated this way, but you can access the easyTravel page by browsing to http://<your_easytravel_host_ip>:8079, which should load up the page and RUM data comes through.



sudo dnf groupinstall workstation
sudo systemctl set-default
sudo yum install java-1.8.0-openjdk chromium firefox screen
sudo reboot


You can run from terminal without GUI, but it needs to be installed so the chromium process can use it.


Best regards,
Jan Kucera

Considering you are using a virtual machine... You can open ports 8094 and 8079 required for the application in your security group and access the application using the public_ip:8094 in any browser. By default it tried to locate firefox application irrespective of OS you use. I hope this helps.



Hi, I installed easyTravel on a centos on azure.
I would like that the loadgenerator is presented to the app towards the public IP instead of localhost.
Is this possible?
This would save me from doing manual traffic and creating synthetics to simulate it.



I'm your friendly neighbourhood Spider-Man!™
- Davide
from Milan, Italy

For completeness' sake and to help others who may have the same request, see the solution to this question here 


Good day, can you help me to know what minimum hardware requirements must have the linux and windows servers for Easy travel to work without problems? Thank you.

Hi @Lufecita22, the memory requirement for the easyTravel components is around 800MB as measured on Windows using the default scenario, according to the table in the original post. Keep in mind that some scenarios may require more or less memory to run, it depends on what the scenario entails.

From my own tests, I'd say a bare minimum of 2GB memory on Linux, and 4GB memory on Windows. For both Linux and Windows, 2 CPU cores (vCPUs) should suffice. If you find that these values don't work, let us know your experience and settings 🤓

@andre_vdveen  I agree with you 100% and is the exact same experience I've had.  And those i would say are the absolute minimum (2GB Linux, 4GB Windows).  Anything less I get some very odd behavior from the system and moments of unresponsiveness, such that I've had to -9 the VM.

To be reliable, on Windows, I've had to run at 8GB.  8GB is costly so that means I can't run it all the time, instead only when I need it.  Even so, it's worth it, this is a really cool tool Dynatrace provides and happy to see are maintaining it.



Where can i find what versions of linux are supported?

Getting this:

sudo /bin/bash
Sorry, Ubuntu 22.04 LTS is not supported.


Here is how to handle dependencies for RedHat:


sudo dnf groupinstall workstation
sudo systemctl set-default
sudo yum install java-1.8.0-openjdk chromium firefox screen
sudo reboot


Best regards,
Jan Kucera


Hello, the same thing happened to me with these two servers, can anyone tell us which versions of Linux are compatible?

Getting this:

Server 1
sudo /bin/bash
Sorry, Ubuntu 22.04.1 LTS is not supported.

Server 2
Sorry, AlmaLinux 8.7 (Stone Smilodon) is not supported.


Thanks ☹️


I looked into that script and I can say that the Linux versions we currently support are:

  • debian 9
  • debian 10
  • ubuntu 16
  • ubuntu 18
  • ubuntu 20
  • centos 7
  • centos 8

Hope this helps 😅

Small update in supported versions. Ubuntu 16 is dropped as it does not support Chromium 90+. But we support ubuntu 22 now. So the updated list is:

  • debian 9
  • debian 10
  • ubuntu 18
  • ubuntu 20
  • ubuntu 22
  • centos 7
  • centos 8

Well, that is all from me 😉

I edited the script and added my version in.

I worked for me and I haven't seen any issues so far.

You can just install firefox and chromium manually and skip, I am running easyTravel on RedHat without any issues.

Best regards,
Jan Kucera

Dynatrace Participant
Dynatrace Participant

Hi team,  
Should you disable monitoring on com.dynatrace.easytravel.weblauncher.jar? I don;t see com.dynatrace.easytravel.launcher.jar running in my test environment.  Kr Ian

Hi Ian,

Yes, please disable monitoring of webaluncher.jar process.

I updated information on page.

Thank you. The original post still says 

"You should disable monitoring of launcher (com.dynatrace.easytravel.launcher.jar easyTravel (x*)) and weblauncher (com.dynatrace.easytravel.weblauncher.jar easytravel-*-x*) processes".

I assume that now turning off deep monitoring for weblauncher.jar is sufficient, correct?

Best regards,
Jan Kucera

Correct. You just have to turn it off for the one you are using and you can find in Dynatrace.

Depending on the way you start easyTravel you will have one "*launcher" jar file monitored - if you don't disable it's monitoring you won't get any RUM data. There are a few ways/scripts to start easyTravel and they may use different "launchers" 🙂


Hello Dynatrace Team,

Currently, the link to download easyTravel is giving me an error of not being able to access the page to download. Not sure if it is something on my end or your end.

Any help is appreciated. Thank you.



Well ... I just tried to download both the windows and linux installers and both downloads work correctly for me.

Can you try one more time? If that does not work, then there is an issue somewhere.

Well, when I go to the website now, it shows the list of installers. Before, it would show me this long url link that took me nowhere. Nothing changed on my end except turning off my PC for the night and then booting it back up this morning.

It seems someone else in my team fixed this and forgot to tell anyone about it... So yes, you are right. There was a problem and it was solved. Thanks for info!


While creating the session in the easyTravel application the Payment Backend (.NET) and B2B frontend (.NET) is not running. How can I solve it?

Well, it is hard to say what is wrong. So let's go with the flow:

  1. Well, I assume that your problem is that when you start a scenario in easyTravel then 2 of the services don't start or crash and are gray, correct?
  2. I assume that you are running easyTravel on Windows - otherwise it won't work.
  3. I assume that during the installation the checkbox for IIS installation was checked - otherwise it also won't work.
  4. I guess that you tried to stop and run it all again and the problem persists and repeats, right?
  5. Can you check you IIS setup? There should be:
    1. 2 extra pools: "dotNetBackend_easyTravel_x64" and "dotNetFrontend_easyTravel_x64"
    2.  2 extra sites: "dotNetBackend_easyTravel_x64" and "dotNetFrontend_easyTravel_x64"
    3. By default the sites should be up and running just like that, so you should be able to visit these services at:
      1. http://localhost:9000/ - the frontend - you should be able to see the page with tiles, but if you click on one of them and try to log in it will fail if easyTravel is not running
      2. http://localhost:9010/ - the payment service
  6. I assume that in the scenario you have started the "Payment Backend (.NET)" and "B2B frontend (.NET)" are both grey - stopped.  Did you try to have a look at the logs - they are located at "C:\Users\YOUR_USER\.dynaTrace\easyTravel 2.0.0\easyTravel\log"? I suggest looking through:
    1. B2BFrontend_9000.log
    2. PaymentBackend.log
    3. WebLauncher.log
  7. Did you try to restart the stopped ".NET" processes? To do that click on the grey process box and select "Start". Did it turn on? If not did something appear in the logs?

So ... this is all I can think of right now. Can you look through my suggestions and say if there is anything out of order that you have noticed? If there are no discoveries then please tell me:

  1. What version of windows are you using?
  2. What version of easyTravel are you running?
  3. Did you change anything during installation?
  4. How did you start easyTravel?
  5. Which scenario are you running?
  6. Did you overwrite any config settings anywhere?

Hope these will help us recreate the problem.

I have followed all your suggestions but the problem persists.
I think the problem is due to the fact that ports 9000 and 9010 are occupied by another application. As you can see from the window that appeared when I reinstalled the application.
Regarding the previous questions: I have windows 11, the version of easyTravel is, ,I didn't change anything during the installation other than the checkbox for IIS and I ran the standard scenario, but the same problem occurs with the others.
Do you think it is the port? How can I solve it?


Well, if the ports are in use by a different application then that probably is the main cause of the problem. You can double check by going to you local addresses and checking if you see our easyTravel stuff or not, I mean trying to go to:

But I guess these won't work. So I have 3 solutions for you:

  1. Find out what application uses those ports, stop that app, restart easyTravel and check if it works.
  2. Create a VM somewhere and install easyTravel there.
  3. And the harder option. So rewire easyTravel. You can modify the easyTravel settings by going to file "C:\Program Files\dynatrace\easyTravel (x64)\resources\". There modify the following lines:
    Set a different port for PaymentService and Frontend. Just set the same value for range start and end of frontend. Apart from doing this, you need to go into the IID applications and rebind them. Restart the sites in IIS as well. After that restart easyTravel. It should work. 




Frequent Guest

Running a Linux install. When I try to run the "/bin/bash" cmd,
I get this error: "Sorry, Red Hat Enterprise Linux 8.7 (Ootpa) is not supported."

Also, When I run "./" I am not able to access the weblauncher via "ip.address:8094" with ip.address being the local 10.xx.xx.xx IP. Is there something I'm missing? Could the above error of from the "/bin/bash" cmd cause the weblauncher to not be accessible?


So... The short answer is: we don't support Red Hat by default, so I don't know what is going on. Please use a supported distribution. 

The long answer is:

  1. You can't run the installChromeDeps script, because it checks if OS matches the distributions we support and installs different libraries for each. Since it does nothing, then most probably the load generator will fail and won't generate any load.
  2. Even if the script was not run correctly I would assume that the console at 8094 should be accessible. Since it is not, well, it is interesting 🙂


So in the end, I would suggest to install easyTravel on a linux distribution that is supported. I will update the information above to make this more obvious.

But if you want to play with it on Red Hat, you can try to look into this directory "/home/YOUR_USER/.dynaTrace/easyTravel 2.0.0/easyTravel/log". There you should be able to find some clues to the errors/exceptions happening somewhere...

DynaMight Champion
DynaMight Champion

Is there a way to change the log directory for easyTravel? The default path seems to be C:\Users\<userId>\.dynaTrace\easyTravel 2.0.0\easyTravel\log on Windows.

You can use `com.dynatrace.easytravel.home.dir.correction`. Note it is relative to the c:\Users\<userId>\.dynaTrace\easyTravel 2.0.0 directory. For example adding


will create directories log, config etc in c:\tmp

Great stuff, thanks @Rafal_Psciuk!
Where do I add that,

I tested it by modifying startup script C:\Program Files\dynaTrace\easyTravel (x64)\weblauncher\weblauncher.cmd:

-Xmx768m ^
%COVERAGE_ARG% %LAUNCHER_ARGS% -Dcom.dynatrace.easytravel.install.dir.correction=.. -Dcom.dynatrace.easytravel.home.dir.correction=\..\..\..\..\tmp -Dorg.eclipse.rap.rwt.enableUITests=true ^ ^
-jar ..\com.dynatrace.easytravel.weblauncher.jar %*


Strange, I tried the same but the logs keep getting written to the default path. I've even copied the text you provided to that file, restarted easyTravel, and even my laptop, but it still won't write to C:\tmp

Either way, thanks for the info...perhaps it will help someone else 😅😉

Are you running <et_install_dir>\weblauncher\weblauncher.cmd?
I checked again. Only some logs landed in c:\tmp directory.
To get backend and frontend logs modify this line in <et_install_dir>\resources\,-Dcom.dynatrace.easytravel.home.dir.correction=\\..\\..\\..\\..\\tmp

However I noticed that after those changes headless load generator (chrome) is crashing. 😞 So I don't recommend using it.


I have deployed the app on windows and I have set the user tag, but it only works for the session I manually do on the application, the synthetic generated visits are not being tagged, why? is there anything else I need to configure so I can get the generated visits tagged?

It should work in the same way. Note, that load is generated only to Angular frontend (port 9079).

Hello @Rafal_Psciuk , can you please specify which option is that? I have tried with UEM-Standard and Production-black friday and I am not getting user tags.

HI @Alejandro_hdez 
It should work in UEM-Standard scenario.
I recommend trying these steps:

1. Setup User tag:

CSS selector: a.greeting

Cleanup rule: Regex: Hi,.(.*+)

2. Start easyTravel with UEM-Standard scenario

3. Verify that you have RUM data for generated visits



Than you @Rafal_Psciuk that selector did work, the one I took browsing the app by my self "#loginForm\:j_idt39" doesn't work.

Now, I'm not able to see session replay correctly, images are not being dispplayed on replay


I'am playing the sessions on Dynatrace on the same host where easytravel is running and I also tried clearing all browsing data and I tried with chrome and edge browsers

Best regards

Hi @Alejandro_hdez ,

AFAIK images will be not available if the application is accessed via http It will also not work when https certificate is self-signed.

Application needs to be accessed via https with valid certificate to have correct session replay.


Hi, in case someone needs, I created Ansible playbook to install easyTravel on RHEL8 or RHEL9. Likely works on other CentOS Stream variants as well. Available in GitHub. Pull requests welcome 😄

Hi Team,


Is that any option to change the URL of Easy travel application from the localhost to Some we are running two instance of easytravel application and we want to differentiate in the application rule.

You can change URLs that are used by load generator by adding following properties to the <et_install_dir>/resources/ file. NOTE: this file will be overwritten after easyTravel installation.


You can also put those properties in the <user_home>/.dynaTrace/easyTravel  2.0.0/easyTravel/config/ file.


Great Post!

I am on Dynatrace Saas and want to monitor EasyTravel via Dynatrace RUM.
I cannot deploy OneAgent, I want to use
this agentless method to monitor it.

Let me know how can I make connection with my cluster and monitor it.

Hi @AdilSaleem 
I never did it, but I would try to add agent in this file: easytravel-2.0.0-x64/angular/webapp/index.html
easytravel-2.0.0-x64 is default easyTravel installation directory; should be changed if you installed it in other place

Featured Posts