cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Synthetic HTTP Monitoring is not working for k8s services via load balancer

Balap
Observer

Hello Champs,

 

Greetings !!

I'm having a tipical issue on synthetic HTTP monitoring via private location. My applications are hosted on k8s and Which are exposed external via load balancer to access through application service urls. as per the k8s structure.. if I use the service name url it will redirect to the right application service to vial load balancer and access it. Now, I'm trying to configure the sythetic monitoring for these services via service specific urls (FQDN)it is failing . I installed the active gateway on the vm and I can able to do the curl for this service url successfully. But when I configure via dynatrace synthetic monitoring it is failing with REQUEST TIMEOUT.   any hints please ?

3 REPLIES 3

radek_jasinski
DynaMight Guru
DynaMight Guru

Hi @Balap 

Have you verified the log entries on the ActiveGate and on the DT server side?

  • /var/log/dynatrace/gateway
  • /var/opt/dynatrace-managed/log/server

I suspect a problem with the proper configuration of network.

Radek

Have a nice day!

HannahM
Dynatrace Leader
Dynatrace Leader

What do you see in 'Analyze last execution'? Is the FQDN being resolved as you expect?
Are you using /etc/hosts file? If so, the HTTP Monitor is unable to use it. Browser Monitors can, so that could be a solution if you need to. 
Are you using any proxies?

 

Balap
Observer

Thanks Mates.

 

It is problem with the Proxy Internal . After I add those details. I am able to set it up.

https://www.dynatrace.com/support/help/shortlink/sgw-proxy-authentication#internal

Thanks for your support

Featured Posts