Showing results for 
Show  only  | Search instead for 
Did you mean: 

Synthetic click not treated as a real user click



we have a blocker for synthetic.

Scenario: if I select the value using dropdown then Bank details should be auto-populated in the below fields however when I make a selection with synthetic or Java script values are not getting populated and come as blank but if I pass the external mouse click event anywhere on Webpage than it works but with synthetic it's not happening, not sure for some reason application is not treating synthetic click as real user click.

Tried passing the Mouse event/Enter key/keystroke then enter on the Synthetic still no luck.

Any suggestions, please


DynaMight Champion
DynaMight Champion


I am not sure but have another problem related to pseudo classes. 

Locators are different for each session, in my case it was so.

I have delete some of them and play back click path. Deleted elements did not affect, the step and test was successfully completed. 


There may be some kind of global JS variable that tells the application whether the form is full or not. It can also be adjusted through editing an action, as we can do similar through the browser developer tools. I would try that way.



Romanenkov Alex


Dynatrace Leader
Dynatrace Leader

If the suggestion above didn't help, please can you create a chat/ support ticket as it would be easier if we can look at the site and give you advice. 

Synthetic SME and community advocate.


Sure Thanks @HannahM 

Dynatrace Leader
Dynatrace Leader

To follow up on this, these clicks were trusted events, which we were unable to interact with. We have added a new feature to cover this scenario which is enabled by adding the following to the configuration section of the script:

,"experimentalProperties": [ 

"name": "enableTrustedEvents", 
"value": "true" 



For Clicks, this is supported from Synthetic 1.266 (1.266 Recorder, 1.266 Public Locations, 1.267 Synthetic AG). The above property enables the script to perform clicks that require the event to be trusted. 

For Keystrokes, this is supported from 1.269 (1.269 Recorder, 1.269 Public Locations, 1.269 Synthetic AG). the above property enables the script to perform keystrokes that require the event to be trusted. 

Synthetic SME and community advocate.

Frequent Guest

Hi Hannah,  

Glad to find this post, but I encountered a new issue after having "enableTrustedEvents"  enabled. 

Some background: 

I have 3 key stroke steps as below: 

a) enter user name

b) enter password

c) enter search string 

  • Scenario 1  - without enableTrustedEvents enabled,  a) & b) works well. but NOT c) 

eg. the search string is like "heat beat"  then c) shows like below(which is not right) 


  • Senario2 - with enableTrustedEvents enabled( in configuraiton section as suggested above)  , c)  issue was solved ( can be seen from synthetic Multidimensional analysis)   

         However, a) hit  timeout error during playback .  weridly, this seemed only happened during playback as no error out in the Synthetic execution.

any idea  how to solve it  ?  Thank you in advance. 





Featured Posts