cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ShahbazKhan
Dynatrace Contributor
Dynatrace Contributor

 

Problem

 

While trying to record a new Synthetic monitor using the Dynatrace Synthetic Recorder, either by clicking record again, for an existing monitor, or record clickpath, for a new monitor, the Incognito, or InPrivate, window  displays the extension blocked message by Microsoft Edge or Google Chrome and never moves on. 

ShahbazKhan_0-1726466368325.png

Text from Image:

pbnfcaobikkbealhienfilklacghhgoi is blocked
This page has been blocked by Chrome
ERR_BLOCKED_BY_CLIENT
 

Root Cause

This behaviour happens when the extension ID is added to the ExtensionInstallForcelist in the regedit

pbnfcaobikkbealhienfilklacghhgoi; https://clients2.google.com/service/update2/crx

This behaviour only occurs when Incognito, or InPrivate, browsing is used.

ShahbazKhan_1-1726466689228.png

 

Solution

Use regedit to set HKLM\Software\Policies\Google\Chrome\DeveloperToolsAvailability = 1 policy if using the ExtensionInstallForcelist policy.

ShahbazKhan_2-1726466904417.png

 

 

Version history
Last update:
‎28 Oct 2024 04:04 PM
Updated by:
Comments
bill_smith
Dynatrace Participant
Dynatrace Participant

What causes the extension to be added to this registry list?  Some anti-malware software?

ShahbazKhan
Dynatrace Contributor
Dynatrace Contributor

It’s mostly via Customer’s Group Policy to ensure uniformity across all devices