cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
bharat_pitta
Dynatrace Enthusiast
Dynatrace Enthusiast

The most common reason for this is that someone has configured a backup location in the Dynatrace UI and forgot to add the mount point to /etc/fstab. If the backup mount is missing elastic search will not start. You can see this in the elasticsearch logs because it will have an ERROR that says path.repo is unavailable.

You have two options to fix this.

  1. Add the NFS mount back to the Filesystem
  2. Disable backups in the UI and restart elasticsearch. If you cannot access the UI or this doesn't work you can manually remove the configuration from the config file.
    The default location for the config file is /opt/dynatrace-managed/elasticsearch/config/elasticsearch.yaml

You will remove the entire line for path.repo and restart elasticsearch.

service dynatrace-elasticsearch stop

service dynatrace-elasticsearch start

Comments
ChadTurner
DynaMight Legend
DynaMight Legend

Great writeup @bharat_pitta 

New Article
Version history
Last update:
‎28 Nov 2022 07:40 PM
Updated by: