cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to generate test problem through event API

AK
Advisor

Hello Folks,

I'm pushing one dummy problem notification through event API and I'm using following URL to test "https://myenv.live.dynatrace.com/api/v1/events".

Below is configuration done under HTTP monitor to generate test/dummy problem.

  1. The request URL is - "https://myenv.live.dynatrace.com/api/v1/events"
  2. HTTP method - POST
  3. Additional HTTP Header - Authorization API token
  4. Request Body - { "eventType": "AVAILABILITY_EVENT",

"timeoutMinutes": 05,

"attachRules": { "entityIds": ["HTTP_CHECK-XYZ"] },

"source": "OpsControl",

"description": "XYZ service is Down" }

But, when I run this monitor the event/problem is not generated and logs entry says "POST https://myenv.live.dynatrace.com/api/v1/events | Failed to resolve hostname for myenv.live.dynatrace.com: Search domain query failed. Original hostname: 'myenv.live.dynatrace.com' failed to resolve 'myenv.live.dynatrace.com' after 12 queries -> [/192.xxx.y.z:53] failed to send a query via UDP (no stack trace available)".

I have tested this under postman and successfully able to generate the problem with desired details.

I don't know why its not working when I configured it through HTTP monitor.

Can anybody please throw some light here.

Thanks...

2 REPLIES 2

wolfgang_beer
Dynatrace Leader
Dynatrace Leader

So if I understand you right, you do post an external event into your own Dynatrace environment by using a Synthetic monitor?

It seems your private synthetic nodes can't resolve the Dynatrace domain.

best greetings,

Wolfgang

Lets me explain it like below.. (I have configured it for testing purpose only)

I want to generate test problem for one HTTP monitor and below is configuration done under same HTTP monitor,

  1. The request URL is - "https://myenv.live.dynatrace.com/api/v1/events"
  2. HTTP method - POST
  3. Additional HTTP Header - Authorization API token
  4. Request Body - { "eventType": "AVAILABILITY_EVENT",

"timeoutMinutes": 05,

"attachRules": { "entityIds": ["HTTP_CHECK-XYZ"] },

"source": "OpsControl",

"description": "Service1 is Down" }

Note:- "HTTP_CHECK-XYZ" is entity ID of same HTTP monitor through which I want to post a problem notification.

Thanks...