cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Communication test fails from mobile agent to SaaS Security Gateway (now ActiveGate)

alejandro_herna
Organizer

We are running a Dynatrace SaaS POC, we instrumented the Android agent
and we want to test the communication between mobile OneAgent and the security
gateway because we are not getting any data on the interface. In the
documentation I found that we can run the test this way:

Using a mobile device browser,
confirm if OneAgent configuration requests deliver a valid response. For
example, https://<psg-url>:<port>/mbeacon/<environment
id>?type=m&app=<app id>
..

This is the cluster URL that I got from the instrumentation page:

DTXClusterURL=https://bf.dynatrace.com



So I tried to run the test with the next URL from the mobile browser:

https://bf.dynatrace.com:9999/mbeacon?type=mt

But it fails, I'm not getting the timestamps, why?


8 REPLIES 8

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Use the syntax described in the doc and it should work.

https://www.dynatrace.com/support/help/deploy-dyna...

Specifically you need something like the following:

https://<tenant>.live.dynatrace.com/mbeacon/<envID>?type=m&app=<appID>

EnvID and AppID are found in the Mobile Application setup screen when setting up (or editing) your mobile app.

BTW: You will not get timestamps back, but rather something like:

type=m&id=5&bl=150

@Patrick H.The syntax that worked was:
https://<environmentID>.bf.dynatrace.com/mbeacon?type=mts
It seems that now it uses the port 443 and not 9999 por SaaS


harp
Dynatrace Pro
Dynatrace Pro


the bf url uses the ELB, so in this case it would be

https://<environmentID>.bf.dynatrace.com:9999/mbeacon?type=mts

So I guess this is why I'm not getting any monitoring data, I have to use this syntax in the instrumentation right? this is not specified in the documentation.


you just have to set the right properties for instrumenting a mobile app like it is shown in the Dynatrace WebUI when you add a mobile app and follow the instrumentation steps.
There is no need to manually construct that url pattern - all settings can be copy pasted from webUI


OK, but the Cluster URL in the WEBUI is not with the envID and the port, as you can see in the image, so I leave like this? I have seen the same cluster URL with different tenants


this is the configuration as you need it for the instrumentation - the agent builds the URL it needs from the properties as URLs for SaaS and managed differ


Thanks for your help @Patrick H.