Showing results for 
Show  only  | Search instead for 
Did you mean: 

Enabling extensions module for ActiveGate on Openshift for Confluent Kafka


Hi Community,

I'm working with the trial version of Dynatrace installed on an enterprise OpenShift cluster purposed for PoCs and trying to get the confluent Kafka extension working. I've installed Dynatrace OneAgent/ActiveGate via the "Deploy Dynatrace" menu and following the steps there. Then I've installed Confluent Kafka extension via the Dynatrace Hub


The base error displayed when entering the error log for my monitoring configuration the Confluent Kafka Monitoring is:




Failed to assign monitoring configuration to ActiveGate. Reason: The monitoring configuration requires ActiveGate version 1.256.0 or later that supports data source prometheus and belongs to group "openshift"




However, I've confirmed that my installation of ActiveGate is above this version. Some searching online has led me to believe that the reason for this is that I don't have extensions 1.0 & extensions 2.0 module enabled for my ActiveGate, which appears to be the case as it doesn't appear on the list.


From here, I've tried editing the configuration directly on the OpenShift pod generated from the auto-configured StatelessSet, referencing the instructions here:

I had to use the following to edit as oc isn't available on the pod. 




cat > [file]
    rpm_enabled = true

    extension_controller_enabled = true
    extension_controller_use_memory_protection_for_fast_check_enabled = true
    extension_controller_fast_check_messages_limit_enabled = true





However, upon restarting the pod, I've found that my configuration is overwritten despite the instructions suggesting otherwise. This seems to be because the Mounted Volumes aren't persistent and always reloaded from my base image for the auto-generated StatelessSet.


Additionally, I've tried restarting the service manually by terminating the service process and allowing it to restart, but the same error is displayed. systemctl command also isn't available on the pod, for reference. 


I have a feeling that I could be missing something as fundamental as a simple toggle in the settings, but I haven't found anything pointing me in that direction yet. Any suggestions on how to troubleshoot this issue would be much appreciated. 






DynaMight Guru
DynaMight Guru

Hi @iqwertyier 

In order to run Extensions 1.0 and 2.0 you need an AG running on a Windows or Linux host (s390 host-based and containerised deployment are not supported)

Zrzut ekranu 2023-11-14 o 08.51.03.png


Have a nice day!

I see, so this means that I will need to extend the dynatrace agent monitoring hosting elsewhere like on an AWS EC2 running linux instead of on Openshift. Thanks for the help. 

Featured Posts