Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error: dtuserag has no access to var/log/dynatrace/gateway when installing activeGate on linux

Hi all, 

We had an outage of the activeGate server. The server was running an old version and tried to upgrade to 1.285 but failed causing that oneagents and activeGate where offline 15 hours. 

to solve the issue we tried to install a new activeGate on the server (linux S.O) but installation failed with 

ERROR: dtuserag has no acces to var/log/dynatrace/gateway ....Installation failed.





Hello, you can try to set back root:root as the owner and modify your folder right with a chmod 755 and retry the installation.

Maybe im getting it wrong, you meant instead of having dtuserag dtuserag, it must appear as the option2 (root root, as you say) in the example image and then apply a chmod 755 to var/log/dynatrace/gateway ?



Yes that is correct. On my AG, folders are assigned to root but my other users/group are at minimal allowed to read/execute.


Dynatrace Champion
Dynatrace Champion

Please uninstall the previous Activegate before installing the new one.

we uninstalled the activegate and manually the folders opt/dynatrace, var/lib/dynatrace, var/temp/dynatrace.

is there any other folder that must be deleted ? 


These are directories used by ActiveGate on GNU/Linux.

Best regards

❤️ Emacs ❤️ Vim ❤️ Bash ❤️ Perl

Featured Posts