Showing results for 
Show  only  | Search instead for 
Did you mean: 

New UI Search (is horrible, doesn't work according to docs). How to make useful?


The new UI is horrible. I don't know how else to describe the functionality removed by the new search. I cannot search for anything without knowing exactly what it is. In the past using this to find groups of things quickly or candidates for troubleshooting sequences or threshold adjusting. At this point if I know the name of the host I can put the name in search and get no results.  I can't type host:hostname as per instructions in documentation and nothing. I have to type:
'>' then type "host" THEN type the 'hostname' to find a single host.  how does this add anything to my experience?  Why wouldn't I just go to hosts then find the host, there?

Please fix.  I really used the ability to open search text in the entire tenant. I find the inability to use it a very strong negative in recommending this product.





This is a very spot-on description of the new search.

If you know exactly where to find something and what it is called - then you might 'find' it - but then - why even bother to search? Some stuff is still not searchable and you are better off just clicking by guessing than using the search.

You really need to work on this - a lot.
If it ain't broke don't fix it. 

Dynatrace Champion
Dynatrace Champion

Hi Nathan, thanks for your feedback! We're aware about the need to "simply search for hosts" or similarly prominent artifacts. We're do plan to improve the current search experience for entities in Grail and we'll provide further details, once an update is available.


For many people at my company, we used the old search quite religiously for learning - finding things in Dynatrace we never knew existed there before. Maybe we know a service name (or part of one). Maybe we know the prefix to a host name, but nothing more. The old search was like one-click to Universal Searching Awesomeness.

I have lots of folks that are avoiding switching to the new GUI simply because they miss/love the old search.

Dynatrace Participant
Dynatrace Participant

Hi all. Thanks for the feedback. We're aware of the limitations you're facing, and are working on improving the experience. It seems like most of the feedback is about searching across multiple entity types simultaneously. In the meantime, while we're working on improvements, I recommend typing ">" followed by "Entities" to search across a selection of common entities. We have similar 'umbrella' categories for "Kubernetes" and "Applications". If there is a need for additional 'umbrella' categories – please provide feedback on those that would be most useful to you.


@uhh you mention that "Some stuff is still not searchable" – can you please provide some details on which categories/sources are missing, and I can confirm if these are on the roadmap.


@nathan_tennant you're right, the docs were outdated. They should be fixed now.

Hi @GabrieleHB , is there any further word on the improvements here?

Being able to search by hitting > and selecting a specific component/category is just not the same.
If I'm searching for an internal service, I expect to be able to search for the name of it, and then to see in the results everything all at once. I should see the processes with that name, any hosts, any dashboards, any synthetic checks, etc. If it's using the same name, I want to see it all at once, not have to explicitly select each individual category within Dynatrace one at a time.

Not looking for a new feature here, just parity with the old search bar.

Sorry for very late reply, and i honestly can't remember what I was about back then.
But as mario_rwwa says in reply to this, the category option is just a tedious and unnecessary step towards finding what you are looking for. Sometimes (and maybe most times) you are looking for connections and "stuff related to" some service, host or whatever, that properly has a naming equality.
I was looking for a db - and I was to decide what category it was. In other words - what type of db is it you are serching for. How should I know - I am not aware of the entire tech stack.
I could find it going though the classis db view and then filter. I guess the example of what not to be able to find was right here then 🙂

Everything was better back in the old days 😄

Featured Posts