Showing results for 
Show  only  | Search instead for 
Did you mean: 

No root access on AIX system when installing OneAgent


I currently cannot execute any command as root after OneAgent Installation for AIX.

When executing any kind of command I get back this error:

/opt/dynatrace/oneagent/agent_install_5374120/others> ls

exec(): 0509-036 Cannot load program ls because of the following errors:

0509-150 Dependent module /opt/dynatrace/oneagent/agent/lib64/ could not be loaded.

0509-022 Cannot load module /opt/dynatrace/oneagent/agent/lib64/

0509-026 System error: A file or directory in the path name does not exist.


As of now I cant even execute the uninstall script. Can tou provide me a solution?


DynaMight Guru
DynaMight Guru

In general dynatrace is creating new user during installation. Check permissions if all is assigned properly.


Regards, Sebastian

DynaMight Legend
DynaMight Legend

It seems you have setup a system-wide preloading or just in the session you are logged in.
Can you write exact steps you did?

It looks as you did insert the LDR_PRELOAD exports into shell profile or probably system wide, which is discouraged.

Try this:


in the shell and see if it helps you to get the control back.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner


the problem was solved like this: I took .profile file of another AIX host on which I was root and I put it in the other Aix host were I was having this issue. After that I was able to execute command as root.

The issue was caused by me when I tried to execute the dynatrace .sh for AIX system for a second time without uninstalling the one that was already up and running.

During the second script exec the second OneAgent tried to uninstall the first giving the error and making impossible for me to use commands as root.

Glad to hear you solved the issue. However, don't set up the environment variables for deep monitoring (those LDR_PRELOAD exports) system-wide or for login users unless you carefully consider the circumstances. You might find yourself unable to login into the system.

Certified Dynatrace Master | Alanata a.s., Slovakia, Dynatrace Master Partner

Featured Posts