cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Fetch the Browser extension config from the Public Activegate (Managed)

ADPaoloni
Mentor

Hi All!

We have a Managed local enviroment, when trying to setup a browser extension RUM, the user cant reach the setup url since the config is trying to fetch it from https://clusterlocaladdress/e/tennantid/api/v1/browserextension/config?Api-Token=tokenid and in our enviroment the cluster aint recheable from outside the local network.

Is there any way to fetch such config from the public activegate, like we fetch the oneagent? (ex: https://publicgateway/e/tennantid/api/v1/browserextension/config?Api-Token=tokenid)?

Thanks in advance!

 

8 REPLIES 8

pahofmann
Champion

I've tried multiple ways and it looks like this is not possible currently.

Maybe someone from dynatrace can chime in and tell me if I missed something. Else you can open an RFE for that feature.


Thanks! I ended open a low severity ticket asking about information if that feature exist. I will open an RFE if it doesn't.


ADPaoloni
Mentor

Just in case of anyone need it, it's possible. Just change the address to the ActiveGate:9999 and works like a charm.


Hi @Dante P.

From where did you take the API token?

I' have tried from the environment and got http error 403

and from the cluster and got http error 401


I created it inside the enviroment and passed it in the url, nothing fancy. I gave all permisions to it.

https://publicactivegate:9999/e/tennantid/api/v1/browserextension/config?Api-Token=tokenid



Hi @Dante P. thanks for your reply.

Odd, for me its keep returning that I have no RumBrwoserExtension permission while all the switches on this API token are on

May I ask what is is your DTM version? here its 1.152.153

Yos


I just check again just in case, since we updated to the new managed versions yesterday. It still works. We are on

**Cluster: 1.152.153.20180921-105102
**Public ActiveGate: 1.151.308.20180919-090035

Created another another app and still works. Do you have the extension app created? When we hit a wall the recomendation was to add a revision=0 to the request, but for us it still works even without that.

Example.

https://activatecage:9999/e/tennantid/api/v1/browserextension/config?revision=0&Api-Token=apitoken


Still not working for me also with the revision=0 getting 403 😞

Will open a ticket on this one and will update ASAP

Thanks for support !

Yos