Showing results for 
Show  only  | Search instead for 
Did you mean: 

Regular ActiveGate for synthetic monitoring

DynaMight Guru
DynaMight Guru

I understand that a regular Environment Activegate cannot do
synthetic monitoring. The reason behind that is explained as the
Synthetic Activegate needing more demanding hardware and system
requirements than a regular Environment. I believe this is due to the
need of installing/executing Chromium.

In a case I have, I
need to do some HTTP monitor measurements, not involving browser
monitors. I already have a regular Activegate, and it seems overkill to
have to install another bigger Activegate only for half a dozen HTTP

Given this, does anyone have answers for some of the following questions:

  • Is it someway possible to do a few HTTP monitor measurements in a regular Activegate, perhaps along the way Jan mentioned in:
  • Is there any planned (or RFE) support for HTTP monitors in a regular Activegate?
  • Is there any planned development for merging Activegates in the future?
Antonio Sousa

DynaMight Legend
DynaMight Legend

Hey @Antonio S. I don't think you can run any synthetics (HTTP/Browser Monitor/Click Paths) without having a dedicated Activegate for it. The reason being is that at time of creation some flags are enabled for this function. You cannot use the "Built in" Activegate in a managed instance either. As of right now you can only use an Activegate to perform 1 type of function at a time. I would recommend tossing in a RFE if you want to see an Actvegate that and handle both Oneagent traffic and synthetics.


Dynatrace Enthusiast
Dynatrace Enthusiast

That is correct Chad. Additionally, If you don't have access to enough resources to run two ActiveGates I recommend running your Synthetic tests from one of our Public Synthetic Locations instead.

@Jay B., It really did work till the environment was updated to version 1.211 this week. Running it from a public location is not possible for me, as they are internal web sites...

Antonio Sousa

DynaMight Guru
DynaMight Guru

HTTP Monitors are no longer enabled by default for Active Gates that route oneagent traffic, as there are Synthetic Active Gates now.

If you just want to run a few HTTP Monitors you can still enable it though

In /var/lib/dynatrace/gateway/config/ add the following:

synthetic_enabled = true

This will enable only HTTP Monitors (not Browser Monitors) for the activegate:

Dynatrace Certified Master - Dynatrace Partner -

Worked flawlessly! Just would add that I had to do a restart of the Activegate.

Antonio Sousa

Yes forgot to mention that, restart is always needed when changing the config file.

The will be persistent throughout upgrades.

Dynatrace Certified Master - Dynatrace Partner -

Dynatrace Champion
Dynatrace Champion

I just wanted to add, that even if described solution for enabling HTTP monitors execution on regular ActiveGates works fine, it is workaround rather than recommended approach.

Regarding the questions about further plans, we do not have ActiveGates unification on the roadmap. What we do have instead in our plans for future is separation of synthetic engine and ActiveGate, making them two completly independent components. Idea of possibility to install both of them on the same machine sounds like valuable input. Thanks a lot!

Best Regards,


Thanks for your input. Seems a reasonable approach, but having the possibility to install both of them on a same machine is quite important in my opinion 🙂

Antonio Sousa

I understand the reasoning for splitting them up. But for very small customers who want to use only a few HTTP Monitors or a short Browser Monitor from a private location it's a valuable option to have everything on one machine.

Dynatrace Certified Master - Dynatrace Partner -

DynaMight Guru
DynaMight Guru

Just a quick note that the tenant 1.211 upgrade broke the AG where I had this working... I had not updated the AG, just in case, but synthetics stopped working after AG was notified of the tenant upgrade.

I then tried to updade AG, but it gives me some error like:

18/02 22:31:45 Package is being installed. Please wait...
18/02 22:31:45 ERROR: Root must not be used to run Synthetic services! Remove USER parameter from installation command or choose another user.
18/02 22:31:45 Installation failed.
18/02 22:31:45 ERROR: Installation process failed. Exit status (5)

Antonio Sousa

So, I have tracked the error further, and it goes like this:

In the installation logs, the following appears

18/02 22:31:45 Dynatrace Synthetic installer version, build date 08.02.2021
18/02 22:31:45 Checking root privileges...
18/02 22:31:45 Determining location of init scripts...
18/02 22:31:45     INIT_FOLDER='/etc/init.d'
18/02 22:31:45 Determining location sgw installation...
18/02 22:31:45     Dynatrace Synthetic installation folder COLLECTOR_INSTALL_DIR_PREFIX='/opt/dynatrace'
18/02 22:31:45     Dynatrace Synthetic log folder COLLECTOR_LOG_DIR_PREFIX='/var/log/dynatrace'
18/02 22:31:45     Dynatrace Synthetic config folder COLLECTOR_CONFIG_DIR_PREFIX='/var/lib/dynatrace'
18/02 22:31:45     Dynatrace Synthetic temp folder COLLECTOR_TEMP_DIR_PREFIX='/var/tmp/dynatrace'
18/02 22:31:45     Dynatrace Synthetic user COLLECTOR_USER='root'
18/02 22:31:45     LOG_DIR='/var/log/dynatrace/synthetic'
18/02 22:31:45     LOG_NAME='/var/log/dynatrace/synthetic/dynatracesynthetic-install_20210218-223145.log'
18/02 22:31:45     DIAGNOSTICS_SCRIPT_LOG_NAME='/var/log/dynatrace/synthetic/dynatracesynthetic-install-diagnostics-script_20210218-223145.log'
18/02 22:31:45     DYNATRACE_SYNTHETIC_AUTO_INSTALL='false'
18/02 22:31:45 Validating installation parameters...
18/02 22:31:45 Verifying user selected to run services...
18/02 22:31:45 ERROR: Root must not be used to run Synthetic services! Remove USER parameter from installation command or choose another user.

Please notice that it defines COLLECTOR_USER as "root", but then it complains it can't use root to run synthetic services

Figuring out how COLLECTOR_USER was being attributed to root was more difficult. I tracked it down to the DTUSER definition in the following file, which is /etc/init.d/dynatracefunctions


Now, it looks like we can specify a user for an AG to run under, with the USER parameter, as described in:

I'm being cautious here, as running synthetic on a normal AG is unsupported. Any clues on how to proceed on this one?

Antonio Sousa

So I figured this one out: I had an old version of Activegate installed. That version was still one that was running as root. I uninstalled it, and installed the new version. It then started running as a different user, and now I have the gateway&synthetic running 🙂

Antonio Sousa

DynaMight Guru
DynaMight Guru

Just a quick note for anyone eventually using this combination, and needs updating because of log4j 2: it still works with 1.229. Please note the following important factors:

  • This is an unsupported combination of Activegates by Dynatrace
  • In our case, it's a small remote Activegate that does routing, synthetics, extensions
  • Automatic updates are not enableable
Antonio Sousa

DynaMight Guru
DynaMight Guru

Just to let everyone that might be running this unsupported configuration know, that in my case, some push configuration from the tenant some 6 hours ago broke the measurements.

The best part is that upgrading from 1.229 to 1.239 solved the issue again, and it is now working again.

I hope this functionality could be officially supported by Dynatrace, as having the possibility for running HTTP monitors (I understand browser monitoring is a different league) from all Activegates would definitely be good for customers, and of course also for Dynatrace (just thinking how much more DEMs would be consumed...)

Antonio Sousa

Featured Posts