Showing results for 
Show  only  | Search instead for 
Did you mean: 

Not possible to create latency SLO using calculated metric


When I try to define the SLO it tells me "At least one operand is empty" but in the data explorer it works, I assume that the problem may be in the entity selector, I tried using the following alternatives:

  1. type("SERVICE_METHOD"),entityId("SERVICE_METHOD-6097AD94763D3D4F")
  2. type("SERVICE"), entityName.startsWith("my_services_name-img.ServicesController")
  3. type("SERVICE"), entityName.startsWith("my_services_name")

This only happens when I use the builtin metric in the denominator, but if I use another one calculated to count the endpoint requests it works.

Attached image as a proof that in the data explorer works

Screen Shot 2021-11-18 at 15.26.41.pngScreen Shot 2021-11-18 at 15.26.55.pngScreen Shot 2021-11-18 at 15.27.32.png

Thanks to those who can provide a solution idea.


DynaMight Pro
DynaMight Pro

Hi, Kenny!


I understood that you are using the Entity Selector field on the SLO config page to filter the metric expression.

And on the Data Explorer, you are filtering through code : " :filter(eq(...)) ".

So, I assume that on SLO you are not applying the filters directly on the code, only on the Entity Selector field... is that it?


If that's the case, could you try using precisely the same metric expression code used on the Data Explorer to configure the SLO (i.e., filtering through code) ?

That way, you could leave the Entity Selector field blank (on the SLO configuration page), as the filters are already written on the code!


Hope it helps!

Best regards, Pedro Deodato

Hi Pedro.

Thank you very much, just leaving blank entity selector and leaving ":filter(eq(...))" in the code worked, that allows us to save the creation of metrics and just create calculated to filter the good events by response time.

Thank you very much. 👍

Featured Posts